Bug 1257218 - ValueError: Cannot remove extended partition sda4. Logical partitions present.
ValueError: Cannot remove extended partition sda4. Logical partitions present.
Status: CLOSED DUPLICATE of bug 1229186
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
ppc64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:b6ccd3358f49a842196f6eaf9fd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 10:14 EDT by Menanteau Guy
Modified: 2015-08-27 08:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-27 08:15:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (390.29 KB, text/plain)
2015-08-26 10:14 EDT, Menanteau Guy
no flags Details
File: anaconda.log (27.29 KB, text/plain)
2015-08-26 10:14 EDT, Menanteau Guy
no flags Details
File: dnf.log (2.94 KB, text/plain)
2015-08-26 10:14 EDT, Menanteau Guy
no flags Details
File: environ (494 bytes, text/plain)
2015-08-26 10:14 EDT, Menanteau Guy
no flags Details
File: lsblk_output (2.56 KB, text/plain)
2015-08-26 10:14 EDT, Menanteau Guy
no flags Details
File: nmcli_dev_list (1.41 KB, text/plain)
2015-08-26 10:14 EDT, Menanteau Guy
no flags Details
File: os_info (451 bytes, text/plain)
2015-08-26 10:14 EDT, Menanteau Guy
no flags Details
File: storage.log (155.42 KB, text/plain)
2015-08-26 10:14 EDT, Menanteau Guy
no flags Details
File: syslog (41.20 KB, text/plain)
2015-08-26 10:14 EDT, Menanteau Guy
no flags Details
File: ifcfg.log (2.23 KB, text/plain)
2015-08-26 10:14 EDT, Menanteau Guy
no flags Details
File: packaging.log (488 bytes, text/plain)
2015-08-26 10:14 EDT, Menanteau Guy
no flags Details
File: program.log (30.48 KB, application/octet-stream)
2015-08-26 10:15 EDT, Menanteau Guy
no flags Details

  None (edit)
Description Menanteau Guy 2015-08-26 10:14:42 EDT
Description of problem:
Install problem when using automatic partitioning on a VM with disks
already partitioned in raid.
This problem occured during test of fedora 23 ppc64 Alpha RC2 image.
http://ppc.koji.fedoraproject.org/compose/23_Alpha_RC2/23/Server/ppc64le/iso/Fedora-Server-DVD-ppc64le-23.iso

You must do two installations
Here after is the procedure:
1 First install.

Select 2 disks (20G each) on installation destination
select "I will configure partitioning"
Remove existing partitions if any.
Create new partitions as follow, using "clic here to create them automatically"
/prepboot de 4M standard partition (FS:prepboot)
/boot de 500M en standar partition (FS:)ext4
/swap de 4G en LVM (FS:swap)
/ de 35.5G en LVM (FS:xfs)
Then reduce / partition size to 8G
Create manually a new raid partition
/home de 5G en RAID -> RAID1 (fs:xfs) 
and install the VM.

This VM seems fine and works correctly.

[root@vm53 ~]# df
Filesystem                   1K-blocks    Used Available Use% Mounted on
devtmpfs                       2038336       0   2038336   0% /dev
tmpfs                          2085440       0   2085440   0% /dev/shm
tmpfs                          2085440    4864   2080576   1% /run
tmpfs                          2085440       0   2085440   0% /sys/fs/cgroup
/dev/mapper/fedora_vm53-root   8378368 1601680   6776688  20% /
tmpfs                          2085440      64   2085376   1% /tmp
/dev/sda2                       487652  136597    321359  30% /boot
/dev/md127                     5232640   32960   5199680   1% /home
tmpfs                           417088       0    417088   0% /run/user/0

[root@vm53 ~]# cat /etc/fstab
#
# /etc/fstab
# Created by anaconda on Tue Aug 25 11:52:54 2015
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/mapper/fedora_vm53-root /                       xfs     defaults        0 0
UUID=7ec09897-f401-4c29-88a4-f72a322a0f1f /boot                   ext4    defaults        1 2
UUID=89acb8b7-263e-4aab-8a40-ac394e0c9553 /home                   xfs     defaults        0 0
/dev/mapper/fedora_vm53-swap swap                    swap    defaults        0 0

[root@vm53 ~]# cat /proc/mdstat
Personalities : [raid1] 
md127 : active raid1 sda5[0] sdb2[1]
      10485760 blocks super 1.2 [2/2] [UU]
      [=======>.............]  resync = 37.8% (3966912/10485760) finish=13.6min speed=7977K/sec
      bitmap: 1/1 pages [64KB], 65536KB chunk

unused devices: <none>

[root@vm53 ~]# cat /proc/mdstat 
Personalities : [raid1] 
md127 : active raid1 sda5[0] sdb2[1]
      5242880 blocks super 1.2 [2/2] [UU]
      bitmap: 1/1 pages [64KB], 65536KB chunk

unused devices: <none>

2 Second install

Reboot the VM for a new install.
Select the 2 disks (20G each) used on the previous install
Choose "Automatically configure partitioning" and press "Done"
At this time the anaconda crashes.

Version-Release number of selected component:
anaconda-23.17-1

The following was filed automatically by anaconda:
anaconda 23.17-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/devices/partition.py", line 485, in removeHook
    "Logical partitions present." % self.name)
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 227, in _removeDevice
    dev.removeHook(modparent=modparent)
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 316, in registerAction
    self._removeDevice(action.device)
  File "/usr/lib/python3.4/site-packages/blivet/blivet.py", line 1091, in destroyDevice
    self.devicetree.registerAction(action)
  File "/usr/lib/python3.4/site-packages/blivet/partitioning.py", line 483, in updateExtendedPartitions
    storage.destroyDevice(part)
  File "/usr/lib/python3.4/site-packages/blivet/partitioning.py", line 573, in doPartitioning
    updateExtendedPartitions(storage, disks)
  File "/usr/lib/python3.4/site-packages/blivet/autopart.py", line 501, in doAutoPartition
    doPartitioning(storage)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/kickstart.py", line 346, in execute
    doAutoPartition(storage, ksdata, min_luks_entropy=MIN_CREATE_ENTROPY)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/kickstart.py", line 2179, in doKickstartStorage
    ksdata.autopart.execute(storage, ksdata, instClass)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 342, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 171, in raise_if_error
    raise exc_info[0](exc_info[1]).with_traceback(exc_info[2])
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 93, in get
    self.raise_if_error(name)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 371, in completed
    retval = (threadMgr.get(constants.THREAD_EXECUTE_STORAGE) is None and
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 217, in _handleCompleteness
    if not spoke.mandatory or spoke.completed:
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 211, in _updateCompleteness
    self._handleCompleteness(spoke, update_continue)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 394, in spoke_done
    self._updateCompleteness(sp, update_continue=False)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 59, in on_back_clicked
    self.main_window.current_action.spoke_done(self)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 949, in on_back_clicked
    NormalSpoke.on_back_clicked(self, button)
ValueError: Cannot remove extended partition sda4.  Logical partitions present.

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/ppc/ppc64/vmlinuz ro
dnf.rpm.log:    Aug 26 13:55:34 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.ppc64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        23
Comment 1 Menanteau Guy 2015-08-26 10:14:46 EDT
Created attachment 1067263 [details]
File: anaconda-tb
Comment 2 Menanteau Guy 2015-08-26 10:14:47 EDT
Created attachment 1067264 [details]
File: anaconda.log
Comment 3 Menanteau Guy 2015-08-26 10:14:48 EDT
Created attachment 1067265 [details]
File: dnf.log
Comment 4 Menanteau Guy 2015-08-26 10:14:49 EDT
Created attachment 1067266 [details]
File: environ
Comment 5 Menanteau Guy 2015-08-26 10:14:51 EDT
Created attachment 1067267 [details]
File: lsblk_output
Comment 6 Menanteau Guy 2015-08-26 10:14:52 EDT
Created attachment 1067268 [details]
File: nmcli_dev_list
Comment 7 Menanteau Guy 2015-08-26 10:14:53 EDT
Created attachment 1067269 [details]
File: os_info
Comment 8 Menanteau Guy 2015-08-26 10:14:55 EDT
Created attachment 1067270 [details]
File: storage.log
Comment 9 Menanteau Guy 2015-08-26 10:14:57 EDT
Created attachment 1067271 [details]
File: syslog
Comment 10 Menanteau Guy 2015-08-26 10:14:58 EDT
Created attachment 1067272 [details]
File: ifcfg.log
Comment 11 Menanteau Guy 2015-08-26 10:14:59 EDT
Created attachment 1067273 [details]
File: packaging.log
Comment 12 Menanteau Guy 2015-08-26 10:15:00 EDT
Created attachment 1067274 [details]
File: program.log
Comment 13 Menanteau Guy 2015-08-27 08:15:26 EDT
This problem is a duplicate of 1229186 as the pyparted used in f23 ppc64 Alpha RC2 is python3-pyparted-3.10.5-2.fc23.ppc64 where correction is not yet applied.

*** This bug has been marked as a duplicate of bug 1229186 ***

Note You need to log in before you can comment on or make changes to this bug.