Bug 125722 - Error activating XKB configuration
Error activating XKB configuration
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
n/a
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-10 12:18 EDT by Gilles J. Seguin
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-20 10:26:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilles J. Seguin 2004-06-10 12:18:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
different from 121984 121016 120858 120989 123626 123724 123732 123893
125640

but same error message

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-2

How reproducible:
Always

Steps to Reproduce:
1. main mennu > preferences > keyboard
2. choose tab "Layouts"
3. in "Available Layout", select French Canadian Basic
4. press "+ Add" button
    

Actual Results:  refer to others bug ID, same thing after step 4.

login in will produce same result, if layout not remove from "selected
layout"


Expected Results:  same result that
setxkbmap ca_enhanced
which succeed

Additional info:

not all layouts are affected, list of one tested but failing.

azerbaijani, bosnian, canadian alternative, farose, Hungarian,
japanese, korean, romanian, swiss, vietnamese
Comment 1 Gilles J. Seguin 2004-06-10 13:45:34 EDT
setxkbmap -layout ca_enhanced  # succeeds and works
setxkbmap -layout "us,de"      # succeeds
setxkbmap -layout "us,ca_enhanced"  # fail
Error loading new keyboard description
setxkbmap -layout "us,az"      # fail as fo, hu, jp, ko
Error loading new keyboard description
setxkbmap -layout "us,ro"      # succeeds, looks special

more info
$  setxkbmap -layout ca_enhanced -print
xkb_keymap {
        xkb_keycodes  { include "xfree86+aliases(qwerty)"       };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include
"en_US(pc105)+ca_enhanced+level3(win_switch)"  };
        xkb_geometry  { include "pc(pc105)"     };
};
 setxkbmap -layout "us,ca_enhanced" -print
xkb_keymap {
        xkb_keycodes  { include "xfree86+aliases(qwerty)"       };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include
"pc/pc(pc105)+pc/us+pc/ca_enhanced:2+level3(win_switch)"        };
        xkb_geometry  { include "pc(pc105)"     };
};


Comment 2 Ajay 2004-06-10 14:35:31 EDT
Here is what I had from my FC-2 installed on partitioned with XP-Home:

Error activating XKB configuration; Probably internal Xserver problem.
Xserver version data:
The X.org foundation
60700,000
-The result of Xprop -root/grepXKB
-The result of gconftool -2-R/desktop/gnome/peripherals/keyboard/XKB
Comment 4 Tom Browder 2004-06-13 05:34:53 EDT
- The result of xprop -root | grep XKB:

_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""

- The result of gconftool-2 -
R /desktop/gnome/peripherals/keyboard/xkb:

 layouts = [us]
 model = pc105
 overrideSettings = false
 options = []
Comment 5 Bill 2004-06-13 22:21:17 EDT
I see the same error message on starting X, or on attempting to make
any change in the configuration tool.

[bbeeman@neptune bbeeman]$ xprop -root | grep XKB 
[bbeeman@neptune bbeeman]$ gconftool-2 -R
/desktop/gnome/peripherals/keyboard/xkb
 layouts = [us]
 model = omnikey101
 overrideSettings = false
 options = [ctrl        ctrl:ctrl_ac]
[bbeeman@neptune bbeeman]$ gconftool-2 -R
/desktop/gnome/peripherals/keyboard/xkb 
[bbeeman@neptune bbeeman]$ cat error1.txt
_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""
Comment 6 Michael Obester 2004-06-14 08:56:58 EDT
I get the error too. This is seen whenever logging in with FC2 as a 
user or root. I performed an upgrade installation over FC1.

Full Error Message:
Error activating XKB configuration
Probably internal X server problem

X server data
The X.Org Foundation
60700000



If you report this as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
Comment 7 Havoc Pennington 2004-06-14 09:52:41 EDT
Isn't this a dup? My memory is that we're currently saying
control-center has the problem, Than fixed KDE by querying the server
dynamically for the xorg vs. xfree86 stuff I think.
Comment 8 Bill 2004-06-14 14:13:20 EDT
This problem (see comment #5) does not appear on a fresh 
installation, but does show up on machines upgraded from FC1.  

Searching in /etc/X11/XF86Config, I find that changing the line

Option   "XkbRules"   "xfree86"

to 

Option   "XkbRules"   "xorg"

resolves the problem.  In the fresh installation there is no 
XF86Config...the corresponding file is xorg.config, and it has the 
correct reference.
Comment 9 Mike A. Harris 2004-06-15 12:59:14 EDT

*** This bug has been marked as a duplicate of 120858 ***
Comment 10 Sergey V. Udaltsov 2004-07-05 08:57:14 EDT
Canadian layout IS broken in 6.7.0 (and xfree). It is not combinable.
Sorry for that. It is fixed in XKeyboardConfig.
Comment 11 Mike A. Harris 2004-07-05 09:59:37 EDT
This bug was marked incorrectly as a duplicate of bug #120858, as
comment number 4, 5, 6, 7, and 8 above incorrectly assumed this
bug report was a duplicate of #120858, and I did too after seeing
all 4 comments in a row and not paying close enough attention.  We
receive so many dupes of that bug, it's kindof a knee-jerk reaction
to dupe them after seeing comments concerning the XkbRules lines in
the X server config file.  ;o)

As Sergey indicates in comment #10, this issue is due to the
ca_enhanced layout being broken in 6.7.0 and not combineable.
The issue will hopefully be resolved when we switch to the new
upstream versions of everything in a future OS release, however
it doesn't seem to be an easy problem to resolve in 6.7.0, so I'm
reopening this issue and changing the status to "DEFERRED" for the
time being, as we probably wont be able to fix this for Fedora
Core 2.

Sorry for the confusion caused by accidental bug duping.
Comment 12 Levente Farkas 2004-07-13 16:32:28 EDT
This means that this bug won't be fixed in fc3 either? AFAIS fc3 test1
still contains 6.7.0:-(
Comment 13 Mike A. Harris 2004-07-13 19:21:43 EDT
We are currently considering shipping the next release of X.Org in
Fedora Core 3, and possibly also the modular xkbdesc packages from
freedesktop.org also, instead of the xkb data files in the monolithic
tree.

That is not yet 100% decided or written in stone yet, but it is our
current line of thinking at this point in time.  If we do decide to
go this route, the packages may be in rawhide sometime in August.

Assuming this problem is fixed upstream already, if we do go to the
new X.Org release for FC3, things should work out ok.  Testing
feedback at that point would be appreciated if possible.

Also, if we do commit to X.Org next release for FC3, I will also be
evaluating the pros and cons of considering releasing it as an update
for FC2 sometime down the road.  This last thought is highly
speculative fantasy idea though than a planned event, so don't tell
people.  ;o)

Comment 14 Marcel Ziswiler 2004-12-03 00:55:03 EST
This bug is still there in FC3, even after today's update to
xorg-x11-6.8.1-12.FC3.21.

$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", ""
$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [us,de_CH]
 model = pc105
 overrideSettings = false
 options = [grp grp:alts_toggle]

This is a fresh install of FC3, no update/upgrade. It worked fine
until I tried to enable Swiss German keyboard (de_CH). This used to
work as long as I can think back (e.g. RH4).
This is highly embarrassing. Do I have to use Micro$oft again!!!
Comment 15 Mike A. Harris 2005-04-20 10:26:11 EDT
The problem reported here, as indicated above, is sue to a long standing
problem in xkb.  Fixing this properly is not a trivial fix, but requires
rather extensive changes to xkb.  The work has been completed already
by Ivan Pascal and Sergey Udaltsov (apologies to Sergey if I've massacred his
name), however it is not integrated into Xorg CVS yet.  Discussions are
underway on Xorg mailing lists to try to find a resolution and bring this
problem to a close for X11R7.

Since it is not possible to fix this problem in any trivial matter in
existing Xorg releases without causing a lot of other regressions, the
problem will only be fixed once Ivan and Sergey's work get integrated
into the upstream CVS, and a new major X version is released.

Closing "WONTFIX" as this problem will not be fixed in existing OS
releases, only a new OS release once it is fixed upstream.
Comment 16 Gilles J. Seguin 2005-04-21 23:41:11 EDT
Do I have to use Micro$oft again!!!

no

i propose work around
working solution #1 
working solution #2
both partial solutions are also presentent, here
http://oclug.on.ca/archives/oclug/2005-January/043030.html

A) alternative working solution #1

An additional comment,
1. main menu > preferences > keyboard
2. choose tab "Layouts"
3. in "Available Layout", select French Canadian Basic
4. press "+ Add" button
will still not work.
see alternative working solution #2 to make it work

step 1: $ setxkbmap us,ca_enhanced,de_ch \
            -option -option grp:rwin_toggle -print
xkb_keymap {
   xkb_keycodes  { include "xfree86+aliases(qwerty)"       };
   xkb_types     { include "complete"      };
   xkb_compat    { include "complete"      };
   xkb_symbols   { include 
     "pc/pc(pc105)+pc/us+pc/ca_enhanced:2+pc/de_ch:3+group(rwin_toggle)"  };
        xkb_geometry  { include "pc(pc105)"     };
}

Step 2a: select 
 "pc/pc(pc105)+pc/us+pc/ca_enhanced:2+pc/de_ch:3+group(rwin_toggle)"
Step 2b: remove "pc/" in front of +pc/ca_enhanced:2+
Step 2c: remove "pc/" in front of +pc/de_ch:3+

Step 3: used the string with setxkbmap
$ setxkbmap -symbols
   "pc/pc(pc105)+pc/us+pc/ca_enhanced:2+pc/de_ch:3+group(rwin_toggle)"

B) alternative working solution #2

if you have root access, in file /usr/X11R6/lib/X11/xkb/rules/xorg
we have
! layout[2]     =       symbols
  *             =       +pc/%l[2]%(v[2]):2
you can remove the pc/ characters
! layout[2]     =       symbols
  *             =       +%l[2]%(v[2]):2
after modification, the second layout given on setxkbmap if it is
ca_enhanced will work, that is
$ setxkbmap us,ca_enhanced,de,es -option -option grp:switch <
    -option grp:rwin_toggle
will work.  Here the ca_enhanced parameter is in position two,
we have us in position one
we have de in position three
ca_enhanced can have be replace by de_CH as possible layout.

1. main menu > preferences > keyboard
2. choose tab "Layouts"
3. in "Available Layout", select French Canadian Basic
4. press "+ Add" button
will work, *IF* only one layout is already there, usually "us".
will fail, more than two layouts are already there.
Comment 17 Gilles J. Seguin 2005-04-22 06:32:39 EDT
in comment #16

Step 2a: select 
 "pc/pc(pc105)+pc/us+pc/ca_enhanced:2+pc/de_ch:3+group(rwin_toggle)"
Step 2b: remove "pc/" in front of +pc/ca_enhanced:2+
Step 2c: remove "pc/" in front of +pc/de_ch:3+

Step 3: used the string with setxkbmap
<<<<<<
$ setxkbmap -symbols
   "pc/pc(pc105)+pc/us+pc/ca_enhanced:2+pc/de_ch:3+group(rwin_toggle)"
======
$ setxkbmap -symbols
   "pc/pc(pc105)+pc/us+ca_enhanced:2+de_ch:3+group(rwin_toggle)"
>>>>>>

Step 2b and Step 2c were not be done. (remove "pc/")

Note You need to log in before you can comment on or make changes to this bug.