Bug 1257243 - RFE: Option for poweroff(1)/reboot(1) to describe why a shutdown/reboot takes place
RFE: Option for poweroff(1)/reboot(1) to describe why a shutdown/reboot takes...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.3
x86_64 Linux
high Severity low
: rc
: ---
Assigned To: Jan Synacek
qe-baseos-daemons
Maxim Svistunov
: FutureFeature, Patch
: 1022191 (view as bug list)
Depends On:
Blocks: 1203710 1298243 1313485 74systemd 1393867
  Show dependency treegraph
 
Reported: 2015-08-26 10:54 EDT by nyelle@redhat.com
Modified: 2017-01-24 08:29 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-24 08:29:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nyelle@redhat.com 2015-08-26 10:54:12 EDT
Description of problem:
Even this might sound very strange, I would like to see an option for 
poweroff(1)/reboot(1) to describe why a shutdown/reboot takes place,
similar like the Microsoft Windows shutdown event tracker. When doing
server maintenance on production systems, I treat it as helpful to know
at a later point when scrolling through the logs why a reboot happened.

Upstream link: https://github.com/systemd/systemd/pull/1029/files

I could imagine something like this:

  reboot -m "Security update of kernel"

Or:

  poweroff -m "Replacement of defunct NIC"

So the goal would be to have this message finally logged in systemd's
journal (or /var/log/messages). I don't know if it makes sense to even
introduce predefined groups (which autofill -m), but my personal needs
would be satisfied with above. I indeed could call logger(1) or so, but
it would be nice to have it along with the command that I run anyway.

Version-Release number of selected component (if applicable):
systemd-208-20.el7_1.5.x86_64

Actual results:
No option for poweroff(1)/reboot(1) to describe why a shutdown/reboot
takes place.

Expected results:
Option for poweroff(1)/reboot(1) to describe why a shutdown/reboot takes
place.
Comment 6 Lukáš Nykrýn 2016-01-12 10:12:02 EST
*** Bug 1022191 has been marked as a duplicate of this bug. ***
Comment 13 Jan Synacek 2016-07-12 08:33:31 EDT
Already upstream (see https://github.com/systemd/systemd/commit/9ef15026c0e7e6600372056c43442c99ec53746e + related commits later).

For RHEL-7, the backport would need a lot more additional testing.
Comment 16 Jan Synacek 2017-01-24 08:29:54 EST
I just realized that backporting is not possible, because, in RHEL7, we still use systemd-shutdownd... Unless there's a strong business reason, we will not re-implement the functionality in RHEL7.

Note You need to log in before you can comment on or make changes to this bug.