Bug 1257268 - N+1 Query when changing hostgroup from the "All Hosts" page
N+1 Query when changing hostgroup from the "All Hosts" page
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Performance (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Ohad Levy
Stephen Benjamin
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 11:27 EDT by Bryan Kearney
Modified: 2016-07-27 04:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 04:55:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 10589 None None None 2016-04-22 11:02 EDT

  None (edit)
Description Bryan Kearney 2015-08-26 11:27:27 EDT
I believe there is a N+1 query when modifying a single host or multiple hosts from the "All Hosts" page of the Foreman. Changing a hostgroup from this page is taking ~5-8 minutes to complete depending on the number of hosts being modified.

Found by loading foreman-rake console
hg = Hostgroup.find_by_id(1)
h = Host.find_by_name("name of host")
h.hostgroup=hg
h.save(:validate => false)

I've attached the specific query that I believe has the N+1. It is executed several times in this block of code which I think is the reason the host group change takes such a long time to complete.
Comment 1 Bryan Kearney 2015-08-26 11:27:28 EDT
Created from redmine issue http://projects.theforeman.org/issues/10589
Comment 5 Bryan Kearney 2015-08-26 14:03:40 EDT
Upstream bug component is Provisioning
Comment 6 Bryan Kearney 2015-08-26 14:43:26 EDT
Upstream bug component is Performance
Comment 7 Bryan Kearney 2015-08-31 02:04:02 EDT
Upstream bug assigned to tcaspy@redhat.com
Comment 8 Bryan Kearney 2015-09-09 10:04:43 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/10589 has been closed
-------------
Tom Caspy
Applied in changeset commit:88275be4587e98092095c501a8a7f58d7bcfaca4.
Comment 10 Stephen Benjamin 2016-03-24 15:25:05 EDT
Verified, as best as I can tell - there's not a number of hosts given for when the performance impact occurs.  however, I tried changing the host group on 10 hosts at once, and it was (nearly) instant.
Comment 14 errata-xmlrpc 2016-07-27 04:55:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.