Bug 1257273 - Heat templates fail on validation
Heat templates fail on validation
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: z2
: 7.0 (Kilo)
Assigned To: Steve Baker
Amit Ugol
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 11:37 EDT by Jeremy
Modified: 2018-02-08 05:52 EST (History)
10 users (show)

See Also:
Fixed In Version: openstack-heat-2015.1.1-4.el7ost
Doc Type: Bug Fix
Doc Text:
Null values are now converted to empty strings. This change was done to prevent validation failures in perfectly valid template resources, which prevented them from being created in previous releases.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 08:20:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
heat template used (2.99 KB, application/x-rar)
2015-08-26 11:37 EDT, Jeremy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1488475 None None None Never

  None (edit)
Description Jeremy 2015-08-26 11:37:57 EDT
Created attachment 1067321 [details]
heat template used

Description of problem:Some heat templates fail on validation


Version-Release number of selected component (if applicable):
7.0

How reproducible:
100%

Steps to Reproduce:
1.heat stack-create -f ./hot.yaml -e ./env.yaml stack01
2.
3.

Actual results:
ERROR: Failed to validate: : resources.APP-server01pair: : sequence item 0: expected string, NoneType found

Expected results:
create stack successfully

Additional info:
https://bugs.launchpad.net/heat/+bug/1488475
The bug link above suggests a workaround that fixed the issue.
Attached is the heat template used.
Comment 4 Steve Baker 2015-08-26 21:36:44 EDT
Is the problem with hot.yaml#55, which isn't valid yaml:

            eth0_otherAllowed: { LIST: [
                "ip_address": { get_param: [NET_info, Net1, cidr] },
            ] }

should probably be

            eth0_otherAllowed: { LIST: [
                {"ip_address": { get_param: [NET_info, Net1, cidr] }},
            ] }

(I just made the same comment upstream)
Comment 5 Zane Bitter 2015-09-04 15:57:00 EDT
That is valid yaml, and no that isn't the problem.
Comment 9 errata-xmlrpc 2015-10-08 08:20:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1865

Note You need to log in before you can comment on or make changes to this bug.