Bug 1257288 - please build libgit2 against libcurl
please build libgit2 against libcurl
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libgit2 (Show other bugs)
23
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Veeti Paananen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1259346
  Show dependency treegraph
 
Reported: 2015-08-26 12:58 EDT by Dirk Hohndel
Modified: 2015-09-03 23:22 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.23.1-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-03 23:22:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dirk Hohndel 2015-08-26 12:58:54 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0
Build Identifier: 

the libgit2 maintainers decided to use libcurl as their advanced transport for http/https based traffic. In order to allow libgit2 to work through http/https proxies it has to be built against libcurl
I believe all that is needed is to have a build requirement for libcurl-devel; the libgit2 cmake file will detect libcurl and automatically build against this.

Reproducible: Always

Steps to Reproduce:
1.build an application against libgit2 (e.g. Subsurface master)
2.try to access an https based git repository while behind a reverse proxy / firewall that blocks direct https access (e.g. try to access Subsurface cloud storage in a typical corporate environment)

Actual Results:  
access to the remote repository fails even if the correct proxies are set up as libgit2 as currently shipped in Fedora isn't built against libcurl and therefore doesn't support http/https proxies

Expected Results:  
access to the remote repository should work with correctly configured proxy settings
Comment 1 Pierre-YvesChibon 2015-09-02 08:28:10 EDT
Ping?

I am a provenpackager and can take care of rebuilding libgit2 with a new BR on libcurl-devel.

This should impact consumers of libgit2 since we're just rebuilding the package, no change in the version, so it sounds like an easy build :)

Let me know if you want to me to care of it.
Comment 2 Veeti Paananen 2015-09-02 09:19:03 EDT
Sorry, I'll get this done in a moment.
Comment 3 Fedora Update System 2015-09-02 11:27:45 EDT
libgit2-0.23.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14884
Comment 4 Fedora Update System 2015-09-03 05:52:29 EDT
libgit2-0.23.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update libgit2'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14884
Comment 5 Fedora Update System 2015-09-03 23:22:42 EDT
libgit2-0.23.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.