Bug 1257300 - [RFE][swift] Increasing ring partition power
[RFE][swift] Increasing ring partition power
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-swift (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity low
: Upstream M2
: 12.0 (Pike)
Assigned To: Pete Zaitcev
Mike Abrams
http://specs.openstack.org/openstack/...
: FutureFeature, Triaged
Depends On:
Blocks: 1442136 1471629
  Show dependency treegraph
 
Reported: 2015-08-26 13:46 EDT by Sean Cohen
Modified: 2018-02-05 14:02 EST (History)
16 users (show)

See Also:
Fixed In Version: openstack-swift-2.14.1-0.20170707093649.4cb76a4.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1471629 (view as bug list)
Environment:
Last Closed: 2017-12-13 15:33:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 155107 None None None 2016-03-10 11:46 EST
OpenStack gerrit 337297 None None None 2016-11-22 04:42 EST
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-15 20:43:25 EST

  None (edit)
Description Sean Cohen 2015-08-26 13:46:36 EDT
Problem Description

The ring power determines the partition to which a resource (account, container or object) is mapped. The partition is included in the path under which the resource is stored in a backend filesystem. Changing the partition power therefore requires relocating resources to new paths in backend filesystems.

In a heavily populated cluster a relocation process could be time-consuming and so to avoid down-time it is desirable to relocate resources while the cluster is still operating. However, it is necessary to do so without (temporary) loss of access to data and without compromising the performance of processes such as replication and auditing.

http://specs.openstack.org/openstack/swift-specs/specs/in_progress/increasing_partition_power.html
Comment 4 Mike McCune 2016-03-28 19:46:50 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 5 Elise Gafford 2016-10-05 07:22:54 EDT
Moving to 11 for triage and prio per discussion with the Swift squad. Resetting acks for reassessment.
Comment 21 errata-xmlrpc 2017-12-13 15:33:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.