Bug 1257303 - [RFE] Update how PEM files are installed with ISO so they are part of a package and not in kickstart %post section.
[RFE] Update how PEM files are installed with ISO so they are part of a packa...
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: ISO Installer (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 1.0
Assigned To: John Matthews
Tasos Papaioannou
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 13:52 EDT by John Matthews
Modified: 2016-09-13 12:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:21:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2015-08-26 13:52:35 EDT
Description of problem:

When we install RHEL + Satellite through the ISO we expect PEM files to be installed noting the products.  This will allow suscription-manager to function.

During tech-preview we approached this problem by modifying the kickstart of the ISO and embedding the PEM files through that mechanism.

For GA we would like to clean this up and have the PEM files come in through a package, similar to the way other layered products approach this....by 
packaging them in one of the product specific packages deploying that 
way. (RHS Gluster uses redhat-storage-server) 

If we need more info we can ping jboggs to help us see an example.
Comment 1 Jason Montleon 2016-06-21 14:59:17 EDT
These should be dropped by fusor-(undercloud)-release now.
Comment 2 Tasos Papaioannou 2016-06-22 16:36:16 EDT
Verified on QCI-1.2-RHEL-7-20160621.t.0:

# rpm -qf /etc/pki/product/*
fusor-release-1.0.0-3.el7_2.noarch
fusor-release-1.0.0-3.el7_2.noarch

# ll /etc/pki/product/*
-rw-r--r--. 1 root root 2171 Jun 17 09:24 /etc/pki/product/201.pem
-rw-r--r--. 1 root root 2151 Jun 17 09:24 /etc/pki/product/250.pem

# rct cat-cert /etc/pki/product/201.pem|awk '$1 == "Name:"'
	Name: Red Hat Software Collections (for RHEL Server)

# rct cat-cert /etc/pki/product/250.pem|awk '$1 == "Name:"'
	Name: Red Hat Satellite


and on QCIOOO-8.0-RHEL-7-20160617.n.2:

# rpm -qf /etc/pki/product/*
fusor-undercloud-release-1.0.0-3.el7_2.noarch
fusor-undercloud-release-1.0.0-3.el7_2.noarch

# ll /etc/pki/product/*
-rw-r--r--. 1 root root 2147 Jun 17 09:27 /etc/pki/product/191.pem
-rw-r--r--. 1 root root 2171 Jun 17 09:27 /etc/pki/product/201.pem

# rct cat-cert /etc/pki/product/191.pem|awk '$1 == "Name:"'
	Name: Red Hat OpenStack

# rct cat-cert /etc/pki/product/201.pem|awk '$1 == "Name:"'
	Name: Red Hat Software Collections (for RHEL Server)
Comment 8 errata-xmlrpc 2016-09-13 12:21:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.