Bug 1257307 - [RFE] Support ceph-disk zapping drives when deploying over existing Ceph nodes
[RFE] Support ceph-disk zapping drives when deploying over existing Ceph nodes
Status: CLOSED DUPLICATE of bug 1377867
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity unspecified
: ---
: 10.0 (Newton)
Assigned To: Hugh Brock
Shai Revivo
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 14:10 EDT by Ryan Brown
Modified: 2016-09-23 17:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-07 19:50:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Brown 2015-08-26 14:10:08 EDT
Description of problem:
If a node has had Ceph on it before and you deploy a fresh Ceph node over it, the deploy fails. To remedy this, currently we need to manually boot each node and "ceph-disk zap /dev/sdFOO" the disks before the deploy can succeed again. 

Version-Release number of selected component (if applicable):
Director GA w/ 0day

How reproducible:
Every time

Steps to Reproduce:
1. Deploy Overcloud w/ 1 or more ceph nodes
2. Delete the stack
3. Deploy again with the same configuration, reusing the hardware from the last deploy

Actual results:
Deploy fails to create ceph nodes.

Expected results:
Deploy succeeds, overwriting the old ceph disks. 

Additional info:
If doing this by default is too much of a change from existing behavior, consider adding a ForceDiskZap parameter to storage-environment.yml that will zap and re-read the partition table when provisioning the nodes. 

This has affected PoC deploys at several customer sites.
Comment 5 Mike Burns 2016-04-07 16:47:27 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 7 John Fulton 2016-09-07 19:50:34 EDT

*** This bug has been marked as a duplicate of bug 1256103 ***
Comment 8 John Fulton 2016-09-23 17:35:32 EDT

*** This bug has been marked as a duplicate of bug 1377867 ***

Note You need to log in before you can comment on or make changes to this bug.