Bug 1257313 - SELinux is preventing abrt-hook-ccpp from using the 'sigchld' accesses on a process.
Summary: SELinux is preventing abrt-hook-ccpp from using the 'sigchld' accesses on a p...
Keywords:
Status: CLOSED DUPLICATE of bug 1245477
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:58900d8012c00daad7257557579...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-26 18:47 UTC by vidhan1995.jain
Modified: 2015-08-27 17:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-27 17:21:45 UTC
Type: ---


Attachments (Terms of Use)

Description vidhan1995.jain 2015-08-26 18:47:13 UTC
Description of problem:
SELinux is preventing abrt-hook-ccpp from using the 'sigchld' accesses on a process.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that abrt-hook-ccpp should be allowed sigchld access on processes labeled kernel_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrt-hook-ccpp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                system_u:system_r:kernel_t:s0
Target Objects                Unknown [ process ]
Source                        abrt-hook-ccpp
Source Path                   abrt-hook-ccpp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-128.10.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.1.5-200.fc22.x86_64 #1 SMP Mon
                              Aug 10 23:38:23 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-08-24 01:23:08 IST
Last Seen                     2015-08-24 01:23:08 IST
Local ID                      6bd3ae38-e637-463c-9c10-d0f817fa19ce

Raw Audit Messages
type=AVC msg=audit(1440359588.951:955): avc:  denied  { sigchld } for  pid=16434 comm="abrt-hook-ccpp" scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=system_u:system_r:kernel_t:s0 tclass=process permissive=0


Hash: abrt-hook-ccpp,thumb_t,kernel_t,process,sigchld

Version-Release number of selected component:
selinux-policy-3.13.1-128.10.fc22.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.1.5-200.fc22.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2015-08-27 17:20:36 UTC
We have fixes in the latest F22 builds.

Please execute

dnf update selinux-policy-targeted --enablerepo=updates-testing

Comment 2 Miroslav Grepl 2015-08-27 17:21:45 UTC

*** This bug has been marked as a duplicate of bug 1245477 ***


Note You need to log in before you can comment on or make changes to this bug.