Bug 1257384 - Compositing corruption under VMware Fusion 8 with HiDPI/Retina display
Compositing corruption under VMware Fusion 8 with HiDPI/Retina display
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: open-vm-tools (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ravindra Kumar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 21:25 EDT by Brion Vibber
Modified: 2015-08-31 15:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-31 15:35:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
host's ~/Library/Logs/VMware Fusion/vmware-vmfusion.log (65.20 KB, text/plain)
2015-08-29 14:32 EDT, Brion Vibber
no flags Details

  None (edit)
Description Brion Vibber 2015-08-26 21:25:30 EDT
Description of problem:

I get some weird visual corruption in window-compositing running Fedora 23 alpha under VMware Fusion 8 on a MacBook Pro 13" (Retina). ... this seems to happen pretty repeatably when running with HiDPI scaling at native Retina resolution (2560x1600), whereas it doesn't occur (so much?) when running at quarter resolution (1280x800).

Seems to be particularly bad with Firefox, which might stress-test the compositing due to heavy use of OpenGL rendering itself.

Screen recording: https://www.youtube.com/watch?v=bcZXec1Inkc


Version-Release number of selected component (if applicable):

open-vm-tools 9.10.2


How reproducible:

Always.


Steps to Reproduce:
1. Get VMware Fusion 8 on a MacBook Pro with Retina display
2. Create VM with Fedora 23 Alpha .iso, set display config to enable native Retina resolution
3. Install Fedora 23 alpha
4. enable hi-dpi mode with: gsettings set org.gnome.desktop.interface scaling-factor 2
5. Open a Terminal window and Firefox
6. Move the Firefox window around the screen


Actual results:

Parts of the Terminal window show through the Firefox window, some colors in Firefox show wrong, etc while moving the Firefox window.

Screen capture: https://www.youtube.com/watch?v=bcZXec1Inkc


Expected results:

Everything should look super smooth and consistent.


Additional info:

Mac is 'MacBook Pro 13" early 2015' model with 16GB system memory. VM configured to VMware hardware version 12; set with 2 CPUs, 4GB memory, 64GB disk, 768MB max video ram, Retina native resolution.
Comment 1 Ravindra Kumar 2015-08-28 23:06:23 EDT
Can you provide a vmware.log from the VM? And, does this still happen if you disable 3D from the VM settings? You might want to open a case with VMware to get this resolved.
Comment 2 Brion Vibber 2015-08-29 14:30:03 EDT
Doesn't happen with 3d acceleration disabled in VM settings, but this forces the desktop to use llvmpipe which is horribly slow at 2560x1600. :)

Can't find much obvious info in the vmware-vmfusion.log but I can attach one...
Comment 3 Brion Vibber 2015-08-29 14:32:54 EDT
Created attachment 1068310 [details]
host's ~/Library/Logs/VMware Fusion/vmware-vmfusion.log
Comment 4 Brion Vibber 2015-08-29 14:43:22 EDT
Filed a ticket with VMware; support req number 15745187808.


Another note: the display corruption doesn't happen in a Wayland session either (but I'm not sure if it's doing full 3d accel in Wayland, everything's a bit more sluggish).
Comment 5 Ravindra Kumar 2015-08-31 15:35:14 EDT
(In reply to Brion Vibber from comment #2)
> Can't find much obvious info in the vmware-vmfusion.log but I can attach
> one...

Actually, you would find vmware.log is the VM's directory. I should have clarified this earlier, sorry about that.

Thanks for all the data. I don't think it is open-vm-tools issue as such. It is either a host side/Fusion issue or some graphics driver issue. Let's continue with the support case you have opened with VMware Support.

I'm marking it as CANTFIX for open-vm-tools.

Note You need to log in before you can comment on or make changes to this bug.