Bug 1257398 - Default value of max_resources_per_stack too low
Default value of max_resources_per_stack too low
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Linux
medium Severity high
: ---
: 10.0 (Newton)
Assigned To: James Slagle
Shai Revivo
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 22:38 EDT by Mark Wagner
Modified: 2016-08-19 16:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-19 16:19:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Wagner 2015-08-26 22:38:14 EDT
Description of problem:

When using RHEL OSP-d to deploy a small cloud (65 bare metal machines), the deployment will run out of resources and fail due to max_resources_per_stack =1000 . Increasing the value allows the deployment to succeed.

Ideally the director should be able to calculate this, if nt, set the value to at least 100000. 
 
Version-Release number of selected component (if applicable):
2015.1.0-4.el7ost

How reproducible:
every time

Steps to Reproduce:
1. Try to deploy 60+ nodes
2.
3.

Actual results:
Deployment runs out of resources and fails

Expected results:

It should just deploy out of the box.

Additional info:

Is there any additional overhead of allowing a higher count if it is not reached ?
(is some amount of system resources set aside for the given value ?)
Comment 3 James Slagle 2015-08-27 12:19:22 EDT

*** This bug has been marked as a duplicate of bug 1240587 ***
Comment 4 chris alfonso 2015-08-28 12:19:40 EDT
Need to wait for https://bugzilla.redhat.com/show_bug.cgi?id=1257401 to be fixed before this is able to be fixed.
Comment 7 Mike Burns 2016-04-07 16:47:27 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 9 Mike Burns 2016-08-19 16:19:53 EDT
The setting appears to be -1 since OSP 8/liberty

https://review.openstack.org/#/c/286746/

Note You need to log in before you can comment on or make changes to this bug.