Bug 1257404 - os-collect-config polling is actually synchronized not random
os-collect-config polling is actually synchronized not random
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-collect-config (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: rc
: 12.0 (Pike)
Assigned To: Alex Schultz
Gurenko Alex
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-26 23:07 EDT by Mark Wagner
Modified: 2018-02-05 14:02 EST (History)
11 users (show)

See Also:
Fixed In Version: os-collect-config-7.0.1-0.20170612052603.5870ed6.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 15:33:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1677314 None None None 2017-03-29 12:24 EDT
OpenStack gerrit 451478 None None None 2017-03-29 12:33 EDT
OpenStack gerrit 454358 None None None 2017-05-18 13:24 EDT

  None (edit)
Description Mark Wagner 2015-08-26 23:07:13 EDT
Description of problem:
Given the nature of the design, the os-collect-config polling is actually synchronized and the 30 sec period causes cpu utilization to go to 100% every 30 seconds for several seconds each poll period.

It is not clear that this is scalable

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1.start top in a window on the undercloud machine
2.start a small deployment (65 nodes)
3.observe top behaviour over time.

Actual results:
Spikes in CPU utilization close to 100% every 30 seconds.

Expected results:
A smoother spread

Additional info:
Comment 3 Steve Baker 2015-08-27 03:26:34 EDT
Making the delay before the first poll a random number between 0 and $period would help de-synchronize the polling for many nodes. This would be a change to os-collect-config.
Comment 6 Mike Burns 2016-04-07 16:47:27 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 8 Thierry Vignaud 2017-06-21 10:14:58 EDT
Changes are in os-collect-config-7.0.1-0.20170612052603.5870ed6.el7ost & openstack-tripleo-heat-templates-7.0.0-0.20170616123155.el7ost
Comment 12 Gurenko Alex 2017-12-04 03:58:27 EST
Verified on build 2017-11-29.2
Comment 15 errata-xmlrpc 2017-12-13 15:33:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.