Bug 125744 - Please add other xfce component deps so /etc/xfce4/xinitrc works as designed
Please add other xfce component deps so /etc/xfce4/xinitrc works as designed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xfce-utils (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-10 15:40 EDT by Jef Spaleta
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-19 11:21:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2004-06-10 15:40:55 EDT
Description of problem:
yum install xfce-utils  doesn't pull in all the 
functionality needed to make /etc/xfce4/xinitrc work
which is called from /usr/bin/startxfce4 
which is called from /usr/share/xsessions/xfce.desktop

There is always a debate raging as to how to package
strictly optional pieces of a desktop environment in such a way
that expected functionality is present for the average user of the
environment, without tying optional deps to packages unnecessarily.
The cd-burning features of nautilus in fedora core, would be a case
example that has set a precendent for tying optional deps to ensure
expected full functionality

In this case, because /etc/xfce4/xinitrc is there to provide
expected functional xfce environment, i think its appropriate for the
package that provides this file to require the strictly optional xfce
components such as xfdesktop and xfwm4 to be installed as well.
Right now, outside of comps.xml grouping there is no easy way to make
sure that when xfce-utils is installed the rest of the xfce pieces get
installed as well to make the xfce4.desktop controlled default session
work as expected.

How to reproduce:
yum install xfce-utils
or up2date xfce-utils
choose xfce session from gdm session list


Actual results:
choosing xfce4 from the gdm menu after yum install xfce-utils
doesn't give a usable xfce environment. At a minimum xfwm4 needs
to be running, though everything expected to be functional in the
xinitfc for xfce4 should be install already as well.

Expected results:
Once the xfce.desktop file is installed and the xfce session is
seen in the gdm Session selection list, all the pieces of xfce the
should be in place ready to be used.

Additional info:
Comment 1 Ngo Than 2004-07-19 11:21:02 EDT
it's fixed in 4.0.6-1. Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.