Bug 1257484 - virt-who hasn't checked "exclude_host_parents" and "filter_host_parents" when it run at rhevm/hyperv mode
virt-who hasn't checked "exclude_host_parents" and "filter_host_parents" when...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-who (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Radek Novacek
xingge
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 03:57 EDT by Liushihui
Modified: 2016-11-30 19:34 EST (History)
6 users (show)

See Also:
Fixed In Version: virt-who-0.14-6.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:57:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liushihui 2015-08-27 03:57:10 EDT
Description of problem:
Since virt-who can't support "exclude_host_parents" and "filter_host_parents" When virt-who run at rhevm/hyperV mode, it hasn't shown any remind info in the virt-who log when virt-who run with these two configures in these two modes.

Version-Release number of selected component (if applicable):
virt-who-0.14-4.el7.noarch
subscription-manager-1.15.9-6.el7.x86_64
python-rhsm-1.15.4-2.el7.x86_64
Satellite6.1.0-20150818.1

How reproducible:
Always

Steps to Reproduce:
1. Register system to Satellite
2. Configure virt-who run with filter_host_parents= in rhevm mode.
# cat /etc/virt-who.d/virt
[test-rhevm1]
type=rhevm
server=https://10.66.79.83:443
username=admin@internal
password=redhat
owner=ACME_Corporation
env=Library
filter_host_parents=
3. Restart virt-who service and check virt-who's log
2015-08-27 15:42:09,803 [DEBUG]  @virtwho.py:126 - Using config named 'test-rhevm1'
2015-08-27 15:42:09,804 [INFO]  @virtwho.py:661 - Using configuration "test-rhevm1" ("rhevm" mode)
2015-08-27 15:42:09,804 [DEBUG]  @virtwho.py:209 - Starting infinite loop with 10 seconds interval
2015-08-27 15:42:10,022 [DEBUG]  @subscriptionmanager.py:112 - Authenticating with certificate: /etc/pki/consumer/cert.pem
2015-08-27 15:42:13,475 [DEBUG]  @subscriptionmanager.py:146 - Checking if server has capability 'hypervisor_async'
2015-08-27 15:42:16,118 [DEBUG]  @subscriptionmanager.py:158 - Server does not have 'hypervisors_async' capability
2015-08-27 15:42:16,118 [INFO]  @subscriptionmanager.py:165 - Sending update in hosts-to-guests mapping: {
    "88d979a3-34f8-4cca-84e8-df0988257ba6": [], 
    "2c014415-c274-40f4-8265-b99c83d3e1aa": [
        {
            "guestId": "a78c947a-b73a-4a95-af96-031b2ba23756", 
            "state": 1, 
            "attributes": {
                "active": 1, 
                "virtWhoType": "rhevm", 
                "hypervisorType": "qemu"
            }
        }, 
    ]
}
2015-08-27 15:42:20,264 [DEBUG]  @subscriptionmanager.py:112 - Authenticating with certificate: /etc/pki/consumer/cert.pem
2015-08-27 15:42:23,289 [DEBUG]  @subscriptionmanager.py:146 - Checking if server has capability 'hypervisor_async'

Actual results:
It hasn't shown any remind info in the virt-who log. Therefore, it's hard for customers to know filter_host_parents has taken effect or not.

Expected results:
It should show some remind info in the virt-who log when virt-who run with these two configures in these two modes
For instance: "filter_host_parents is not support in rhevm mode now, ignore it"

Additional info:
When virt-who run at hyperv mode, it has the same problem.
Comment 1 Radek Novacek 2015-08-27 10:55:21 EDT
Fixed in virt-who-0.14-6.el7.
Comment 3 Liushihui 2015-09-05 22:59:18 EDT
It still exist on virt-who-0.14-7.el7.noarch, virt-who still hasn't check "exclude_host_parents" and "filter_host_parents" when it run at rhevm/hyperv mode.Therefore, reopen it.


[root@hp-z220-05 ~]# rpm -q virt-who
virt-who-0.14-7.el7.noarch

Do as the bug's description and check the virt-who's log.  virt-who still can't show any remind info in the log. please see detail as the following:
2015-09-06 10:54:26,980 [DEBUG]  @virtwho.py:132 - Using config named 'test-rhevm1'
2015-09-06 10:54:26,980 [INFO]  @virtwho.py:696 - Using configuration "test-rhevm1" ("rhevm" mode)
2015-09-06 10:54:26,980 [DEBUG]  @virtwho.py:215 - Starting infinite loop with 3600 seconds interval
2015-09-06 10:54:27,347 [DEBUG]  @subscriptionmanager.py:112 - Authenticating with certificate: /etc/pki/consumer/cert.pem
2015-09-06 10:54:31,346 [DEBUG]  @subscriptionmanager.py:146 - Checking if server has capability 'hypervisor_async'
2015-09-06 10:54:35,165 [DEBUG]  @subscriptionmanager.py:158 - Server does not have 'hypervisors_async' capability
2015-09-06 10:54:35,166 [INFO]  @subscriptionmanager.py:165 - Sending update in hosts-to-guests mapping: {
    "4c9d0d7f-ef81-4ce1-8a29-ed81ae1ecc42": []
}
Comment 4 Radek Novacek 2015-09-08 06:33:20 EDT
What config did you use? When I test it with the config from the description:

[test-rhevm1]
type=rhevm
server=https://10.66.79.83:443
username=admin@internal
password=redhat
owner=ACME_Corporation
env=Library
filter_host_parents=

I can see warning "filter_host_parents is not supported in rhevm mode, ignoring it" in the log file.
Comment 5 Liushihui 2015-09-09 01:23:57 EDT
Radek, I'm sorry I ignore these warning msg since it's on the first line. It's definitely has been resolved on virt-who-0.14-7.el7.noarch. The warning msg as the following:

2015-09-09 13:21:02,650 [WARNING]  @config.py:102 - filter_host_parents is not supported in rhevm mode, ignoring it
2015-09-09 13:21:02,651 [WARNING]  @config.py:104 - exclude_host_parents is not supported in rhevm mode, ignoring it

Therefore,verify it.
Comment 6 errata-xmlrpc 2015-11-19 06:57:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2370.html

Note You need to log in before you can comment on or make changes to this bug.