Bug 1257516 - License for less should be BSD
License for less should be BSD
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: less (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Viktor Jancik
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 05:03 EDT by Sitsofe Wheeler
Modified: 2016-01-31 21:25 EST (History)
3 users (show)

See Also:
Fixed In Version: 471-5.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-24 04:26:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sitsofe Wheeler 2015-08-27 05:03:03 EDT
Description of problem:
The RPM spec for less says less's license is GPLv3+ whereas it should be BSD(-like).

Version-Release number of selected component (if applicable):
less-471-4.fc22.x86_64

How reproducible:
Reproducible every time.

Steps to Reproduce:
1. rpm -qi less | grep Lic

Actual results:
License     : GPLv3+

Expected results:
License     : BSD

Additional info:
less is one of the few GNU projects (along with ncurses) that doesn't have a GPL license despite what http://www.gnu.org/software/less/ says. /usr/share/licenses/less/LICENSE seems to look two clause BSD like (https://fedoraproject.org/wiki/Licensing:BSD?rd=Licensing/BSD#2ClauseBSD ) and was flagged as BSD by FOSSology.
Comment 1 Sitsofe Wheeler 2015-08-28 10:14:43 EDT
Further inspection seems to suggest it's actually dual licensed: GPLv3 and BSD. From the README:

[...]
This program is free software. You may redistribute it and/or
modify it under the terms of either:

1. The GNU General Public License, as published by the Free
Software Foundation; either version 3, or (at your option) any
later version. A copy of this license is in the file COPYING.
or
2. The Less License, in the file LICENSE.

So
Expected results:
License     : GPLv3+ or BSD
Comment 2 Fedora Update System 2015-09-02 08:42:18 EDT
less-479-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14867
Comment 3 Fedora Update System 2015-09-02 09:05:47 EDT
less-471-5.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14870
Comment 4 Sitsofe Wheeler 2015-09-03 02:07:58 EDT
This release doesn't appear to fix the license issue in the RPM spec itself:

# rpm -qi less
Name        : less
Version     : 471
Release     : 5.fc22
Architecture: x86_64
Install Date: Thu 03 Sep 2015 06:55:16 BST
Group       : Applications/Text
Size        : 298361
License     : GPLv3+

http://pkgs.fedoraproject.org/cgit/less.git/commit/?h=f22&id=12956e7bcd23072fa08a0caf67458b8401a1eae7 shows the spec changing the files that are packaged but there's no change to the license field itself.
Comment 5 Fedora Update System 2015-09-03 05:52:39 EDT
less-479-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update less'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14867
Comment 6 Fedora Update System 2015-09-03 15:20:49 EDT
less-471-5.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update less'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14870
Comment 7 Fedora Update System 2015-09-04 15:45:47 EDT
less-479-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Sitsofe Wheeler 2015-09-04 18:35:24 EDT
Hang on - I don't think the problem is fixed. See comment #4 - the license in the RPM spec file is unchanged...
Comment 9 Fedora Update System 2015-09-24 04:26:36 EDT
less-471-5.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.