Bug 1257520 - python-gluster package is not getting installed in RHEL7
python-gluster package is not getting installed in RHEL7
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: build (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity high
: ---
: RHGS 3.3.1
Assigned To: Milind Changire
Vivek Das
: ZStream
Depends On:
Blocks: 1475688
  Show dependency treegraph
 
Reported: 2015-08-27 05:14 EDT by Vivek Das
Modified: 2017-11-28 22:29 EST (History)
11 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-52
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-28 22:29:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3276 normal SHIPPED_LIVE glusterfs bug fix update 2017-11-29 03:28:52 EST

  None (edit)
Description Vivek Das 2015-08-27 05:14:30 EDT
Description of problem:

While doing an yum update on a RHEL7 setup the 'python-gluster' package is not getting installed instead throwing an error and skipping the install. 

The python-gluster package is supposed to be pulled in as dependent package of 'swiftonfile'.


Version-Release number of selected component (if applicable):

glusterfs-3.7.1-12.el7rhgs.x86_64
swiftonfile-1.13.1-3.el7rhgs.noarch

How reproducible:

Always

Steps to Reproduce:
1. yum update
2.
3.

Actual results:

python-gluster skips install

Expected results:

python-gluster should get installed as the dependent package of swifton file.

Additional info:
Comment 6 Timothy Asir 2017-11-07 07:33:07 EST
I have tested gluster import using http://download.eng.bos.redhat.com/brewroot/work/tasks/1707/14471707/python-gluster-3.8.4-51.1.git95ba1073f.el7rhgs.noarch.rpm and seen it was working fine.
Comment 10 Vivek Das 2017-11-13 09:51:24 EST
Looks good to me. Able to pull python-gluster package. Marking this as verified.
Comment 13 errata-xmlrpc 2017-11-28 22:29:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3276

Note You need to log in before you can comment on or make changes to this bug.