Bug 1257530 - Log file should not be stored under tmpfs-ed /run
Log file should not be stored under tmpfs-ed /run
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 05:41 EDT by Jan Pazdziora
Modified: 2018-05-22 03:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-05-15 10:10:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2015-08-27 05:41:00 EDT
Description of problem:

After fresh ipa-server-install, there is file /run/certmonger/.ipa/log/renew.log created. Given /run is mounted as tmpfs, the log file will get lost after reboot.

Version-Release number of selected component (if applicable):

ipa-server-4.2.0-5.el7.x86_64
certmonger-0.78.4-1.el7.x86_64

How reproducible:

Deterministic.

Steps to Reproduce:
1. Install ipa-server, run ipa-server-install.
2. Check /run/certmonger/.ipa/log.

Actual results:

There is /run/certmonger/.ipa/log/renew.log there.

Expected results:

No log file there.

Additional info:

On this particular installation, the log file is actually empty, even if I also saw upstream installation in container which had

2015-08-26T15:32:24Z	94	MainThread	ipa.ipalib.session.MemcacheSessionManager	WARNING	session memcached servers not running
2015-08-26T15:32:24Z	101	MainThread	ipa.ipalib.session.MemcacheSessionManager	WARNING	session memcached servers not running
2015-08-26T15:32:24Z	98	MainThread	ipa.ipalib.session.MemcacheSessionManager	WARNING	session memcached servers not running
2015-08-26T15:32:24Z	96	MainThread	ipa.ipalib.session.MemcacheSessionManager	WARNING	session memcached servers not running
2015-08-26T15:32:24Z	97	MainThread	ipa.ipalib.session.MemcacheSessionManager	WARNING	session memcached servers not running

in it -- pretty important information not to be lost.
Comment 2 Petr Vobornik 2015-08-27 06:43:05 EDT
the 
ipa.ipalib.session.MemcacheSessionManager	WARNING	session memcached servers not running

is a bug in IPA API initialization. 

Honza, could you check the log.
Comment 3 Jan Cholasta 2015-09-01 06:11:19 EDT
The log file is bogus, it is created automatically by IPA when API is initialized in dogtag-ipa-ca-renew-agent, which logs everything into syslog rather than the log file.

The script is executed by certmonger, which does not have access to memcached, hence the warning. It is not a bug in API initialization, but rather the session manager code.
Comment 5 Petr Vobornik 2015-09-01 10:05:05 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5280
Comment 7 Petr Vobornik 2017-04-06 12:23:56 EDT
IdM team doesn't have capacity to fix this bug for RHEL 7.4. Moving to next RHEL version. Fixing the bug there will depend on capacity of FreeIPA upstream. Without sufficient  justification there is a chance that it will be moved again later.
Comment 9 Petr Vobornik 2018-05-15 10:10:31 EDT
The message was removed by not using memcached in FreeIPA 4.4.
Comment 10 Jan Pazdziora 2018-05-21 06:14:35 EDT
I'm sorry but the concern in this bugzilla was not the content of the log file, it was the sole fact that something which serves as log file is not stored where it likely should. I don't think this bugzilla should be CLOSED/CURRENTRELEASE unless the location of that log file has changed, in which case it should likely go through normal QE cycle.
Comment 11 Rob Crittenden 2018-05-21 13:47:12 EDT
The IPA framework logs to $HOME/.ipa/log. The idea was to maintain something like bash_history. It is unimportant to maintain in the certmonger case.
Comment 12 Jan Pazdziora 2018-05-22 03:33:42 EDT
In that case, the correct resolution is WONTFIX or NOTABUT, not CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.