Bug 1257534 - PATCH: fix opengl hangs on NV46 cards
PATCH: fix opengl hangs on NV46 cards
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 05:46 EDT by Hans de Goede
Modified: 2016-02-15 10:35 EST (History)
7 users (show)

See Also:
Fixed In Version: 4.1.6-201.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-15 10:35:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2015-08-27 05:46:49 EDT
Hi,

There is a problem with nv46 based cards hanging while waiting for vsync, due to MSI interrupts not working reliable with these cards.

There was some discussion upstream on how to best fix this, this has been fixed now by a patch which disables MSI interrupts on these cards:

http://cgit.freedesktop.org/~darktama/nouveau/commit/?id=cdb40514ebc062a72c7451aeecb6066d0dd4a9a8

This patch has been queued for merging into 4.3, but since this bug makes these cards practically unusable and the patch is quite simple I would like to ask you to include the patch in Fedora kernel builds until it trickles downstream.

Thanks & Regards,

Hans
Comment 1 Josh Boyer 2015-08-27 10:53:55 EDT
(In reply to Hans de Goede from comment #0)
> Hi,
> 
> There is a problem with nv46 based cards hanging while waiting for vsync,
> due to MSI interrupts not working reliable with these cards.
> 
> There was some discussion upstream on how to best fix this, this has been
> fixed now by a patch which disables MSI interrupts on these cards:
> 
> http://cgit.freedesktop.org/~darktama/nouveau/commit/
> ?id=cdb40514ebc062a72c7451aeecb6066d0dd4a9a8
> 
> This patch has been queued for merging into 4.3, but since this bug makes
> these cards practically unusable and the patch is quite simple I would like
> to ask you to include the patch in Fedora kernel builds until it trickles
> downstream.
> 
> Thanks & Regards,
> 
> Hans

Added on all branches.  I had to munge the path in the patch because the nouveau tree uses that weird directory layout, but otherwise it's identical.
Comment 2 Fedora Update System 2015-09-01 10:59:53 EDT
kernel-4.2.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14782
Comment 3 Fedora Update System 2015-09-01 16:22:03 EDT
kernel-4.2.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update kernel'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14782
Comment 4 Fedora Update System 2015-09-03 23:23:30 EDT
kernel-4.2.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2015-09-04 21:03:24 EDT
kernel-4.1.6-201.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15130
Comment 6 Fedora Update System 2015-09-06 14:52:13 EDT
kernel-4.1.6-201.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update kernel'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15130
Comment 7 Fedora Update System 2015-09-11 13:21:34 EDT
kernel-4.1.6-201.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2015-09-15 13:36:00 EDT
kernel-4.1.7-100.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15933
Comment 9 Fedora Update System 2015-09-16 21:02:30 EDT
kernel-4.1.7-100.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update kernel'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15933
Comment 10 Fedora Update System 2015-09-22 20:20:09 EDT
kernel-4.1.7-100.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.