Bug 1257551 - tests: sleep for 60 sec during cleanup and volume start for freeing ports
tests: sleep for 60 sec during cleanup and volume start for freeing ports
Status: CLOSED WORKSFORME
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 06:25 EDT by Gaurav Kumar Garg
Modified: 2017-08-08 11:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-08 11:23:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaurav Kumar Garg 2015-08-27 06:25:26 EDT
Description of problem:

sleep 60 sec to free the prot which is used by previous regression run
    
There might be a case when static port used by daemons in glusterfs will
not free b/w two consecutive regression test run. Linux System might take
60 sec to free the port.
    
Currently linux regression test is failing because of this. port for nfs
daemon is not freed by previos test run.

for eg:
https://build.gluster.org/job/rackspace-regression-2GB-triggered/13718/consoleFull


How reproducible:

Intermediate
Comment 1 Gaurav Kumar Garg 2015-08-27 06:29:37 EDT
upstream patch link: http://review.gluster.org/12029
Comment 2 Raghavendra Talur 2016-03-08 14:53:46 EST
"tests" component is for tests framework only.
File a bug under test component if you find a bug in 
1. any of the *.rc files under tests/ 
2. run-tests.sh


For everything else, the bug should be filed on
1. component which is being tested by .t file if the .t file requires fix.
2. component which is causing a valid .t file to fail in regression.

I have used my best judgement here to move the bug to right component.
In case of ambiguity, I have placed the blame on the .t file component.

Please consider test bugs under the same backlog list that tracks other bugs in your component.
Comment 3 Mike McCune 2016-03-28 18:22:31 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 5 Atin Mukherjee 2017-08-08 11:23:57 EDT
This fix doesn't look like required any more. Closing this issue.

Note You need to log in before you can comment on or make changes to this bug.