Bug 1257574 - After installing oracle-xe-selinux, oracle-xe fails to configure after installation
After installing oracle-xe-selinux, oracle-xe fails to configure after instal...
Status: CLOSED DUPLICATE of bug 1258563
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
2.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 07:33 EDT by Lukáš Hellebrandt
Modified: 2015-09-02 06:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-02 06:24:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
audit.log (9.10 KB, text/plain)
2015-08-27 07:33 EDT, Lukáš Hellebrandt
no flags Details

  None (edit)
Description Lukáš Hellebrandt 2015-08-27 07:33:40 EDT
Created attachment 1067689 [details]
audit.log

Description of problem:
When oracle-xe-selinux is installed, oracle-xe fails to configure after installation ('/etc/init.d/oracle-xe configure'). AVC denials in audit.log attached.
The error message is 'Database Configuration failed. Look into /u01/app/oracle/product/11.2.0/xe/config/log for details'. The files in that directory contain multiple Oracle errors: 'ORA-01034: ORACLE not available', 'ORA-27101: shared memory realm does not exist', 'ORA-00600: internal error code, arguments: [SKGMHASH], [1], [18446744072646661188], [0], [0], [], [], [], [], [], [], []'.

After 'setenforce 0' or without oracle-xe-selinux, installation works and the database runs (tested using sqlplus).

Version-Release number of selected component (if applicable):
oracle-xe-11.2.0-1.0.x86_64
oracle-xe-selinux-10.2.0.40-1.fc21.noarch

How reproducible:
Always on Fedora 21, 22

Steps to Reproduce:
yum remove oracle-xe -y; yum install oracle-xe -y; yum --nogpgcheck -y install oracle-lib-compat; yum -y upgrade selinux-policy selinux-policy-targeted; yum  --nogpgcheck -y install oracle-xe-selinux; /etc/init.d/oracle-xe configure

while

tail -F /var/log/audit/audit.log

Actual results:
AVCs, errors in /u01/app/oracle/product/11.2.0/xe/config/log , the database is not configured

Expected results:
The database should be configured and run correctly
Comment 1 Pavel Studeník 2015-09-02 06:24:44 EDT

*** This bug has been marked as a duplicate of bug 1258563 ***

Note You need to log in before you can comment on or make changes to this bug.