Bug 125762 - machine freezes with matrox millennium card
machine freezes with matrox millennium card
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-10 18:26 EDT by Patrick Smears
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 18:59:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from when the system is working (36.78 KB, text/plain)
2004-06-10 18:29 EDT, Patrick Smears
no flags Details
Xorg.0.log from when the system crashes (46.57 KB, text/plain)
2004-06-10 18:56 EDT, Patrick Smears
no flags Details
My X configuration (15.04 KB, text/plain)
2004-06-10 18:57 EDT, Patrick Smears
no flags Details
The correct logfile for the "crash" case (35.50 KB, text/plain)
2004-07-07 18:09 EDT, Patrick Smears
no flags Details
Server log with xorg-x11 version 6.7.0-5 (35.51 KB, text/plain)
2004-07-21 18:01 EDT, Patrick Smears
no flags Details
Output of "system-config-display --reconfig" (161 bytes, text/plain)
2004-07-21 18:12 EDT, Patrick Smears
no flags Details
xorg.conf produced by system-config-display --reconfig -noui (2.67 KB, text/plain)
2004-07-21 18:26 EDT, Patrick Smears
no flags Details

  None (edit)
Description Patrick Smears 2004-06-10 18:26:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:

When X is started, and the Matrox Millennium graphics card is
configured, the machine freezes (black screen, no response to
keyboard, stops responding to pings).

The machine is dual-head, and if only the other graphics card is
configured, it works fine. If only the Matrox card is configured, 
the freeze still happens.

If I replace the files "mga_drv.o" and "mga_dri.o" with their
equivalents from RH8.0 (XFree86-4.2.1-23), the problem goes away. (I
replaced these driver files rather than installing the full package
since dependency issues make it hard to downgrade to that version of
X).

It does seem to indicate that the problem is in one of these driver
files, since everything else (configuration files, HW setup etc) is
identical.

The same problem existed in FC1 but not in RH8.0.


Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-2

How reproducible:
Always

Steps to Reproduce:
1. Ensure the Matrox Millennium card is configured in XFree86
2. Type 'startx' or set the runlevel to 5

    

Actual Results:  The screen turns black, and there is no response to
keyboard, mouse
or network. A reboot is necessary.

Expected Results:  The desktop or graphical login screen should appear.

Additional info:


I shall attempt to gather the X server logfiles from when the
system is working / not working.
Comment 1 Patrick Smears 2004-06-10 18:29:18 EDT
Created attachment 101049 [details]
Xorg.0.log from when the system is working

This is the X server log from when the machine is working (i.e. when the
FC2 'mga*.o' files have been overwritten with the RH8.0 versions).
Comment 2 Patrick Smears 2004-06-10 18:56:22 EDT
Created attachment 101050 [details]
Xorg.0.log from when the system crashes

This is the X server log file from when the system crashes (i.e. when
the unmodified FC2 packages are installed).
Comment 3 Patrick Smears 2004-06-10 18:57:44 EDT
Created attachment 101051 [details]
My X configuration
Comment 4 Mike A. Harris 2004-07-07 03:05:52 EDT
For the attached X server logs, did you reboot into text mode
after the crash, and make backup copies of the X server logs,
or did you start the X server up, and then attach the logs found
in /var/log afterward?

Curious, because the log files both show the X server starting
up, but without any crash information in it.  If you crash, and
then start up X again, the new log file overwrites the log file
from the crash.

Nothing stands out as being wrong in either log.

Please try the following:

Upgrade to the latest xorg-x11 release for FC2 (6.7.0-5), and then
run:

system-config-display --reconfig

Configure your multihead this way, then save the configuration,
and restart.  Does the problem go away?
Comment 5 Patrick Smears 2004-07-07 18:09:33 EDT
Created attachment 101700 [details]
The correct logfile for the "crash" case


Many thanks for looking into this.

I did indeed start up in text mode and copy the log file; however I seem to
have managed to add entirely the wrong log file. I'm attaching the correct one
now.

This file does not appear to have any crash information in it either - but this

may be consistent with the fact that the machine froze entirely (rather than
just the X server process). (I had mounted the filesystem with "sync" to ensure

that as much of the log as possible got written to disk before the system
hung.)

I am currently downloading the latest xorg-x11 packages; I will try out your
suggestion and post the results.
Comment 6 Patrick Smears 2004-07-21 18:01:35 EDT
Created attachment 102121 [details]
Server log with xorg-x11 version 6.7.0-5


Simply upgrading to the latest xorg-x11 (6.7.0-5), without changing the
X configuration, resulted in exactly the same symptoms as before - machine
freezes, does not respond to keyboard or network, must be power cycled.

The new server log is attached - again, there does not appear to be any crash
info generated.
Comment 7 Patrick Smears 2004-07-21 18:12:33 EDT
Created attachment 102122 [details]
Output of "system-config-display --reconfig"


Running "system-config-display --reconfig" as suggested produces the attached
errors, and does not create an xorg.conf file.
Comment 8 Patrick Smears 2004-07-21 18:26:34 EDT
Created attachment 102123 [details]
xorg.conf produced by system-config-display --reconfig -noui


Running "system-config-display --reconfig -noui" does produce an xorg.conf
file, which is attached.

This configuration file does not work, due to the lack of a "BusID" line. Once
the appropriate BusID line has been added, the machine freezes in the same
manner as always - no response to keyboard or network.
Comment 9 Patrick Smears 2004-07-21 18:30:06 EDT
One more data point: if I replace just the mga_drv.o file with the one
from RH8.0 (XFree86-4.2.1-23), the problem goes away - suggesting the
problem lies within this file (rather than mga_dri.o, which I was
also replacing before).

Please let me know if there is any more information I can provide.
Comment 10 Bill Guelker 2004-08-19 15:22:31 EDT
I can confirm this bug.  I herd about 7 older machines with G200 cards
and VIA VT82C598 chipsets.  After upgrading to FC1, these machines
began to freeze solid on X startup -- but only about half the time. 
When this happened, X logs terminated in the middle without any
additional information (usually shortly after the DDC probing). 
Sometimes a reboot would bring the machines up, sometimes they would
hang again before showing the gdm login screen.  FC2 exhibited the
same behavior.

I could also often get the machines to hang by running
system-config-display, so I think it has something to do with the
probing. 

Following the suggestions above, I copied mga_drv.o from a RH9
machine, and the problem appears to be solved.  I would note that my
situation differs from the above only in that the systems didn't
freeze every time X started, but seemed to hang randomly about half of
the time.

I will be happy to provide any additional information that might be
helpful.
Comment 11 Mike A. Harris 2004-08-19 17:22:19 EDT
This problem, which occurs on certain Millenium and Mystique models
is fixed in rawhide xorg-x11 6.7.99.902, which I believe to be the
same problem described here.  Please upgrade xorg to the rawhide
version to confirm if the problem is fixed for you.

Setting status to "RAWHIDE".  If the issue persists after testing
this version, please file a bug report in X.Org bugzilla and paste
the URL here and reopen this report and we will track the issue
in the upstream bugzilla.

    http://bugs.freedesktop.org  - xorg component

Thanks for testing.
Comment 12 Patrick Smears 2004-08-26 17:38:49 EDT
I installed the Rawhide xorg-x11 (xorg-x11-6.7.99.902-4.i386.rpm and
friends), but saw exactly the same problem, same symptoms. I have
raised the issue on the x.org bugzilla:

   https://freedesktop.org/bugzilla/show_bug.cgi?id=1194
Comment 13 Mike A. Harris 2004-08-30 18:59:20 EDT
Ok thanks, we'll track the issue in the upstream bug report now.

Thanks for the feedback and testing.

Note You need to log in before you can comment on or make changes to this bug.