Bug 1257621 - QoS is not dispalyed in 'setup host networks' -> 'edit network' dialog (for unattached networks)
QoS is not dispalyed in 'setup host networks' -> 'edit network' dialog (for u...
Status: CLOSED DEFERRED
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.3.0
: ---
Assigned To: Alona Kaplan
Michael Burman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 09:27 EDT by Martin Mucha
Modified: 2017-07-16 11:05 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-16 11:05:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.3?


Attachments (Terms of Use)

  None (edit)
Description Martin Mucha 2015-08-27 09:27:48 EDT
Description of problem:
QoS is not dispalyed in 'setup host networks' -> 'edit network' dialog

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. create host and network with hostnetwork qos assigned to it.
2. open setup host networks dialog and assing this network to some nic.
3. click pencil to edit network details.

given network has hostnetwork qos assigned. So it should be displayed in this dialog.

4. click cancel to get back to setup host networks dialog
5. confirm to attach this network to given nic.
6. redo steps 2 and 3 to get back to edit network details.

notice that qos data are filled up.

Actual results:

hostnetwork qos data should be filled at first attempt.



Additional info:
Comment 1 Alona Kaplan 2015-12-30 07:37:08 EST
Let us postpone this fix after bug 1242230 (gui refactoring) is done, as it is caused by a mixup between VdsNetworkInterface data and NetworkAttachment data.
Comment 2 Sandro Bonazzola 2016-05-02 05:47:57 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 3 Yaniv Lavi 2016-05-23 09:12:54 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 4 Dan Kenigsberg 2017-07-16 11:05:19 EDT
Unfortunately, researching into this has not been a priority.

Note You need to log in before you can comment on or make changes to this bug.