Bug 1257622 - 'bundle help list' shows help for 'bundle show'
'bundle help list' shows help for 'bundle show'
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rubygem-bundler (Show other bugs)
7.2
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Vít Ondruch
Iveta Wiedermann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 09:28 EDT by Iveta Wiedermann
Modified: 2015-08-31 04:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-31 04:29:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Iveta Wiedermann 2015-08-27 09:28:49 EDT
Description of problem:
'bundle help list' command provides the same output as for 'bundle help show' command. It looks like if no GEM is provided to 'bundle show' its behaviour is same as for 'bundle list' but still I think 'bundle help list' should not have in usage 'bundle show GEM [OPTIONS]'.
And if 'bundle show' without a GEM specified should be the same as 'bundle list' it should be also mentioned in man page.


Version-Release number of selected component (if applicable):
rubygem-bundler-1.7.8-3.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1.bundle help show
2.bundle help list
3.and compare the outputs

Actual results:
bundle help list

Usage:
  bundle show GEM [OPTIONS]

Options:
      [--paths=List the paths of all gems that are required by your Gemfile.], [--no-paths]  
      [--no-color=Disable colorization in output], [--no-no-color]                           
  -V, [--verbose=Enable verbose output mode], [--no-verbose]                                 
  -r, [--retry=Specify the number of times you wish to attempt network commands]             

Description:
  Show lists the names and versions of all gems that are required by your Gemfile. Calling show with [GEM] 
  will list the exact location of that gem on your machine.

Expected results:
bundle list should have its own description in help

Additional info:
Comment 1 Vít Ondruch 2015-08-31 04:29:23 EDT
Thank you for your report.

Looking at the source code [1], it seems that the "list" and "show" commands are equivalent. Nevertheless, the "bundle help" has different description for them. So I asked upstream [2] to clarify this.

However, I am closing this issue, since I don't think it is worth of separate fix in RHEL.



[1] https://github.com/bundler/bundler/blob/master/lib/bundler/cli.rb#L206
[2] https://github.com/bundler/bundler/issues/3972

Note You need to log in before you can comment on or make changes to this bug.