Bug 1257660 - OpenSCAP UI still informs user to distribute SCAP content, when it is no longer required.
Summary: OpenSCAP UI still informs user to distribute SCAP content, when it is no long...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: SCAP Plugin
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Shlomi Zadok
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-27 14:46 UTC by Rich Jerrido
Modified: 2019-09-26 14:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:18:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
Image illustrating the notice (50.21 KB, image/png)
2015-08-27 14:46 UTC, Rich Jerrido
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 11604 Normal Closed OpenSCAP UI still informs user to distribute SCAP content, when it is no longer required. 2020-05-11 14:20:35 UTC
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Rich Jerrido 2015-08-27 14:46:36 UTC
Created attachment 1067784 [details]
Image illustrating the notice

Description of problem:

When creating a new OpenSCAP policy, the user is informed to 'Ensure the selected SCAP content exists on your hosts' . However, the content, if not present on the host, in downloaded via the Satellite/Capsule. 

The UI needs to be updated to remove this statement. 

Version-Release number of selected component (if applicable):
openscap-1.2.4-1.el7sat.x86_64
openscap-scanner-1.2.4-1.el7sat.x86_64
puppet-foreman_scap_client-0.3.3-9.el7sat.noarch
puppetlabs-stdlib-4.2.1-1.20140510git08b00d9.el7sat.noarch
ruby193-rubygem-foreman_openscap-0.3.2.10-1.el7sat.noarch
ruby193-rubygem-openscap-0.4.2-2.el7sat.noarch
ruby193-rubygem-scaptimony-0.3.0.1-1.el7sat.noarch
rubygem-smart_proxy_openscap-0.3.0.9-1.el7sat.noarch
scap-security-guide-0.1.19-2.el7.noarch


How reproducible:
100%

Steps to Reproduce:
1. Create a new SCAP policy via Hosts->Policies
2. On Step 2 (SCAP Content), the Notice is displayed
3.

Actual results:
Satellite states that they user needs to distribute content


Expected results:
Satellite does not state that the user needs to distribute content.

Additional info:

Comment 1 Bryan Kearney 2015-08-28 17:36:08 UTC
Created redmine issue http://projects.theforeman.org/issues/11604 from this bug

Comment 2 Bryan Kearney 2015-08-28 17:51:03 UTC
Upstream bug component is SCAP Plugin

Comment 3 Bryan Kearney 2015-09-12 16:04:21 UTC
Upstream bug assigned to szadok@redhat.com

Comment 4 Bryan Kearney 2015-09-17 16:04:49 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11604 has been closed

Comment 8 Kedar Bidarkar 2016-03-31 19:36:07 UTC
VERIFIED with sat62-snap6

This message is no longer displayed.

Comment 10 errata-xmlrpc 2016-07-27 09:18:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.