This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1257686 - Multiple tools have permission problems
Multiple tools have permission problems
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: amanda (Show other bugs)
24
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Josef Ridky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 12:39 EDT by Trever Adams
Modified: 2016-09-02 19:21 EDT (History)
4 users (show)

See Also:
Fixed In Version: amanda-3.3.9-3.fc24 amanda-3.3.9-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-02 16:53:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trever Adams 2015-08-27 12:39:19 EDT
Description of problem:
bash-4.3$ amdump normal
Can't locate Tie/StdHash.pm:   ./Tie/StdHash.pm: Permission denied at /usr/share/perl5/base.pm line 99.
	...propagated at /usr/share/perl5/base.pm line 108.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/Amanda/Config/FoldingHash.pm line 3.
Compilation failed in require at /usr/lib64/perl5/vendor_perl/Amanda/Config.pm line 753.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/Amanda/Config.pm line 753.
Compilation failed in require at /usr/sbin/amdump line 29.
BEGIN failed--compilation aborted at /usr/sbin/amdump line 29.

bash-4.3$ amcleanup normal
Can't locate Tie/StdHash.pm:   ./Tie/StdHash.pm: Permission denied at /usr/share/perl5/base.pm line 99.
	...propagated at /usr/share/perl5/base.pm line 108.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/Amanda/Config/FoldingHash.pm line 3.
Compilation failed in require at /usr/lib64/perl5/vendor_perl/Amanda/Config.pm line 753.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/Amanda/Config.pm line 753.
Compilation failed in require at /usr/sbin/amcleanup line 26.
BEGIN failed--compilation aborted at /usr/sbin/amcleanup line 26.

Version-Release number of selected component (if applicable):
amanda-3.3.7p1-1.fc22.x86_64
amanda-client-3.3.7p1-1.fc22.x86_64
amanda-libs-3.3.7p1-1.fc22.x86_64
amanda-server-3.3.7p1-1.fc22.x86_64
Comment 1 Petr Hracek 2016-02-09 05:32:58 EST
There is a bug with the latest upstream version 3.3.8.
Could you please verify whether the bug is fixed?

Relevant scm-commit is http://pkgs.fedoraproject.org/cgit/rpms/amanda.git/commit/?h=f22&id=c6e090ceb846020b43893aaac1779faf3551a60e

If the bug is fixed, close the bug please.
Comment 2 Trever Adams 2016-03-07 09:05:49 EST
This is a no go still.

bash-4.3$ amdump normal
Can't locate Tie/StdHash.pm:   ./Tie/StdHash.pm: Permission denied at /usr/share/perl5/base.pm line 99.
	...propagated at /usr/share/perl5/base.pm line 108.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/Amanda/Config/FoldingHash.pm line 3.
Compilation failed in require at /usr/lib64/perl5/vendor_perl/Amanda/Config.pm line 753.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/Amanda/Config.pm line 753.
Compilation failed in require at /usr/sbin/amdump line 29.
BEGIN failed--compilation aborted at /usr/sbin/amdump line 29.
bash-4.3$ exit
exit
[root@ ~]# rpm -qa | grep amanda | sort
amanda-3.3.8-1.fc23.x86_64
amanda-client-3.3.8-1.fc23.x86_64
amanda-libs-3.3.8-1.fc23.x86_64
amanda-server-3.3.8-1.fc23.x86_64
Comment 3 Fedora Admin XMLRPC Client 2016-07-11 06:13:36 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Josef Ridky 2016-07-28 02:07:55 EDT
New upstream version of amanda (3.3.9) has been released.
Could you please verify whether the bug is fixed?

Relevant scm-commit is http://pkgs.fedoraproject.org/cgit/rpms/amanda.git/commit/?h=f23&id=007ffffec08a253feccd096f25a82000f5fd1a39

If the bug is fixed, close the bug please.
Comment 5 Trever Adams 2016-08-01 19:56:05 EDT
# dnf --enablerepo=updates-testing upgrade 'amanda*'
y
Fedora 24 - x86_64 - Test Updates                    724 kB/s | 2.8 MB     00:03    
Fedora 24 - x86_64 - Updates                         1.3 MB/s |  13 MB     00:09    
Last metadata expiration check: 0:00:23 ago on Mon Aug  1 17:54:10 2016.
Dependencies resolved.
=====================================================================================
 Package              Arch          Version             Repository              Size
=====================================================================================
Upgrading:
 amanda               x86_64        3.3.9-1.fc24        updates-testing        253 k
 amanda-client        x86_64        3.3.9-1.fc24        updates-testing        279 k
 amanda-libs          x86_64        3.3.9-1.fc24        updates-testing        753 k
 amanda-server        x86_64        3.3.9-1.fc24        updates-testing        574 k

Transaction Summary
=====================================================================================
Upgrade  4 Packages

Total download size: 1.8 M
Is this ok [y/N]: Downloading Packages:
(1/4): amanda-3.3.8-1.fc24_3.3.9-1.fc24.x86_64.drpm  105 kB/s | 115 kB     00:01    
(2/4): amanda-libs-3.3.8-1.fc24_3.3.9-1.fc24.x86_64. 185 kB/s | 225 kB     00:01    
(3/4): amanda-server-3.3.8-1.fc24_3.3.9-1.fc24.x86_6 136 kB/s | 264 kB     00:01    
(4/4): amanda-client-3.3.9-1.fc24.x86_64.rpm         325 kB/s | 279 kB     00:00    
[DRPM] amanda-3.3.8-1.fc24_3.3.9-1.fc24.x86_64.drpm: done                           
[DRPM] amanda-libs-3.3.8-1.fc24_3.3.9-1.fc24.x86_64.drpm: done                      
[DRPM] amanda-server-3.3.8-1.fc24_3.3.9-1.fc24.x86_64.drpm: done                    
-------------------------------------------------------------------------------------
Total                                                184 kB/s | 882 kB     00:04     
Delta RPMs reduced 1.8 MB of updates to 0.9 MB (52.1% saved)
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Upgrading   : amanda-libs-3.3.9-1.fc24.x86_64                                  1/8 
  Upgrading   : amanda-3.3.9-1.fc24.x86_64                                       2/8 
  Upgrading   : amanda-server-3.3.9-1.fc24.x86_64                                3/8 
  Upgrading   : amanda-client-3.3.9-1.fc24.x86_64                                4/8 
  Cleanup     : amanda-client-3.3.8-1.fc24.x86_64                                5/8 
  Cleanup     : amanda-server-3.3.8-1.fc24.x86_64                                6/8 
  Cleanup     : amanda-3.3.8-1.fc24.x86_64                                       7/8 
  Cleanup     : amanda-libs-3.3.8-1.fc24.x86_64                                  8/8 
  Verifying   : amanda-3.3.9-1.fc24.x86_64                                       1/8 
  Verifying   : amanda-libs-3.3.9-1.fc24.x86_64                                  2/8 
  Verifying   : amanda-server-3.3.9-1.fc24.x86_64                                3/8 
  Verifying   : amanda-client-3.3.9-1.fc24.x86_64                                4/8 
  Verifying   : amanda-3.3.8-1.fc24.x86_64                                       5/8 
  Verifying   : amanda-client-3.3.8-1.fc24.x86_64                                6/8 
  Verifying   : amanda-libs-3.3.8-1.fc24.x86_64                                  7/8 
  Verifying   : amanda-server-3.3.8-1.fc24.x86_64                                8/8 

Upgraded:
  amanda.x86_64 3.3.9-1.fc24               amanda-client.x86_64 3.3.9-1.fc24         
  amanda-libs.x86_64 3.3.9-1.fc24          amanda-server.x86_64 3.3.9-1.fc24    

The problem still exists.

bash-4.3$ amdump normal
Can't locate Tie/StdHash.pm:   ./Tie/StdHash.pm: Permission denied at /usr/share/perl5/base.pm line 99.
	...propagated at /usr/share/perl5/base.pm line 108.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/Amanda/Config/FoldingHash.pm line 3.
Compilation failed in require at /usr/lib64/perl5/vendor_perl/Amanda/Config.pm line 753.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/Amanda/Config.pm line 753.
Compilation failed in require at /usr/sbin/amdump line 29.
BEGIN failed--compilation aborted at /usr/sbin/amdump line 29.
Comment 6 Trever Adams 2016-08-02 13:36:40 EDT
Additionally, amdump now complains "'/usr/bin/tar' binary is not secure".

This appears to be an incorrect.
Comment 7 Fedora Update System 2016-08-04 08:01:18 EDT
amanda-3.3.9-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7b6f54ca75
Comment 8 Fedora Update System 2016-08-04 08:01:31 EDT
amanda-3.3.9-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2acd2eed98
Comment 9 Josef Ridky 2016-08-04 08:15:20 EDT
I have just added patch from upstream, which should solve described problem.

If the problem will not persist, please close this bug, otherwise I will looking for another solution.

Relevant scm-commit is: http://pkgs.fedoraproject.org/cgit/rpms/amanda.git/commit/?h=f24&id=222578a274145fd9dc6b74b3f0dcfa6424a30ce4
Comment 10 Fedora Update System 2016-08-04 19:51:10 EDT
amanda-3.3.9-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2acd2eed98
Comment 11 Fedora Update System 2016-08-04 19:52:18 EDT
amanda-3.3.9-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7b6f54ca75
Comment 12 Trever Adams 2016-08-05 15:28:12 EDT
Ok, the original problem seems to be fixed.

http://wiki.zmanda.com/man/amanda-security.conf.5.html

Seems to suggest the file is NOT required if things are at the default locations and not symlinks. These conditions are true, but the file must exist.
Comment 13 Fedora Update System 2016-08-18 06:51:34 EDT
amanda-3.3.9-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9ff34eaec5
Comment 14 Fedora Update System 2016-08-18 06:52:04 EDT
amanda-3.3.9-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ee1a82a83e
Comment 15 Fedora Update System 2016-08-18 20:23:29 EDT
amanda-3.3.9-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ee1a82a83e
Comment 16 Fedora Update System 2016-08-18 20:59:27 EDT
amanda-3.3.9-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9ff34eaec5
Comment 17 Trever Adams 2016-08-19 10:30:45 EDT
Thank you. As far as I can tell, this bug (both parts) has/have now been fixed. Thank you very much!
Comment 18 Fedora Update System 2016-09-02 16:53:43 EDT
amanda-3.3.9-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2016-09-02 19:21:23 EDT
amanda-3.3.9-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.