Bug 1257687 - horizon proxy is not http mode
horizon proxy is not http mode
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity unspecified
: z2
: 7.0 (Kilo)
Assigned To: Emilien Macchi
Ido Ovadia
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 12:42 EDT by Ryan O'Hara
Modified: 2015-10-08 08:23 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-2015.1.8-14.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, the HAProxy configuration for Horizon did not enable HTTP mode, which is needed because a cookie is used for persistence. As a consequence, an error similar to the following occurred: [WARNING] 238/115010 (13878) : config : cookie will be ignored for proxy 'horizon' (needs 'mode http') This update adds "mode => 'http'" to the configuration, which resolves this problem.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 08:23:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 218383 None None None Never

  None (edit)
Description Ryan O'Hara 2015-08-27 12:42:29 EDT
The haproxy configuration for horizon does not have 'mode http' set. This proxy needs to be in http mode since it is using a cookie for persistence. The default section has 'mode tcp', which is fine, but horizon proxy needs to override this setting to get http mode. Without this, you will likely see an error like this:

[WARNING] 238/115010 (13878) : config : cookie will be ignored for proxy 'horizon' (needs 'mode http').
Comment 4 Emilien Macchi 2015-08-28 12:31:38 EDT
Please review this patch which attempts to fix the bug: https://review.openstack.org/218383
Comment 9 errata-xmlrpc 2015-10-08 08:23:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1872

Note You need to log in before you can comment on or make changes to this bug.