Bug 1257690 - haproxy should use UDP logging [NEEDINFO]
haproxy should use UDP logging
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Jay Dobies
Udi Shkalim
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 12:47 EDT by Ryan O'Hara
Modified: 2016-04-07 17:39 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.7-10.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:39:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oblaut: needinfo? (rohara)


Attachments (Terms of Use)

  None (edit)
Description Ryan O'Hara 2015-08-27 12:47:14 EDT
It is higly recommended to use UDP logging for haproxy. Currently, rhel-osp-director will configure haproxy to log to the /dev/log UNIX socket. Since max_dgram_qlen it most likely quite small, you will likely get warnings at startup:

[ALERT] 238/115010 (13878) : sendto logger #1 failed: Resource temporarily unavailable (errno=11)

There are two solutions:

1. Use UDP logging by changing the log line to this:

   log 127.0.0.1 local0

2. Increase the max_dgram_qlen via sysctl.

   cat /proc/sys/net/unix/max_dgram_qlen
   # probably 10
Comment 4 Yanis Guenane 2015-09-11 09:55:53 EDT
Those 3 reviews address the issue mentioned in the ticket. Both solution 1 and 2.

However, tripleo-heat-templates does not configure rsyslog daemons on the machines, hence 127.0.0.1:514 in UDP is not available out of the box.

I think this request should be made as a RFE. (ie. make t-h-t configure rsyslog deamons on the hosts)

TripleO-Heat-Templates review (Solution 1): https://review.openstack.org/#/c/222602/
TripleO-Heat-Templates review (Solution 2): https://review.openstack.org/#/c/222612/
Puppet-TripleO review : https://review.openstack.org/#/c/222595/
Comment 5 Yanis Guenane 2015-10-16 05:49:33 EDT
Upstream review merged
Comment 12 errata-xmlrpc 2016-04-07 17:39:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.