Bug 125770 - "hpoj" line becomes commented out in /etc/sane.d/dll.conf
"hpoj" line becomes commented out in /etc/sane.d/dll.conf
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hpoj (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-11 05:05 EDT by Daniel Malmgren
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-04 06:40:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Malmgren 2004-06-11 05:05:41 EDT
Description of problem:
Neither scanimage nor xsane works with my scanner. They worked last
time I scanned (some month ago) and now they don't.

Version-Release number of selected component (if applicable):
sane-backends-1.0.14-1
hpoj -0.91-7

How reproducible:
100%

Additional info:
[~#] ptal-init status
ptal-init has been started.
[~#] ptal-device
mlc:usb:psc_1100_series

Sane-find-scanner finds my scanner allright, however scanimage doesn't
seem to:
[~#] sane-find-scanner
 
  # No SCSI scanners found. If you expected something different, make
sure that
  # you have loaded a SCSI driver for your SCSI adapter.
  # Also you need support for SCSI Generic (sg) in your operating
system.
  # If using Linux, try "modprobe sg".
 
found USB scanner (vendor=0x03f0 [Hewlett-Packard], product=0x3011 [psc
1100 series]) at libusb:003:002
  # Your USB scanner was (probably) detected. It may or may not be
supported by
  # SANE. Try scanimage -L and read the backend's manpage.
 
  # Not checking for parallel port scanners.
 
  # Most Scanners connected to the parallel port or other proprietary
ports
  # can't be detected by this program.
[~#] scanimage -L
 
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).


I'm running latest devel rpm's of everything, and a self-compiled
vanilla 2.6.6 kernel.
Comment 1 Daniel Malmgren 2004-06-14 11:07:21 EDT
Found out what the problem was and now it's working allright. I think
this should be fixed though:

The problem was that the hpoj line was commented out of dll.conf. I
can't really tell why, it hasn't been commented out before. I guess
some rpm script should be fixed in the libsane-hpoj package? When that
package is installed hpoj should automatically be enabled in sane,
shouldn't it?
Comment 2 Tim Waugh 2004-06-24 13:30:21 EDT
This line should be added (uncommented) when you install libsane-hpoj.
 Perhaps it gets overwritten when sane is upgraded?

$ rpm -q --scripts libsane-hpoj
postinstall scriptlet (using /bin/sh):
/sbin/ldconfig
# Add HPOJ driver to /etc/sane.d/dll.conf
if ! grep ^hpoj /etc/sane.d/dll.conf >/dev/null 2>/dev/null ; then \
        echo hpoj >> /etc/sane.d/dll.conf; \
fi
preuninstall scriptlet (using /bin/sh):
# Remove HPOJ driver from /etc/sane.d/dll.conf
if [ "$1" = 0 ]; then \
        if grep ^hpoj /etc/sane.d/dll.conf >/dev/null 2>&1 ; then \
                sed '/^hpoj$/d' /etc/sane.d/dll.conf > \
                        /etc/sane.d/dll.conf.rpmmod; \
                mv -f /etc/sane.d/dll.conf.rpmmod \
                        /etc/sane.d/dll.conf; \
        fi; \
fi
postuninstall program: /sbin/ldconfig
Comment 3 Daniel Malmgren 2004-06-24 14:23:01 EDT
Doesn't seem so. Upgraded sane-backends today, it didn't change the
dll.conf file. Can't really understand how I got into the faulty state...
Comment 4 Amish S. Dave 2004-09-20 04:26:23 EDT
I also had a dll.conf file that had hpoj commented out somehow. 
unfortunately, uncommenting it doesn't fix things for me.

HP PSC2175 printer connected to x86 via USB
kernel 2.6.8.1 and 2.6.9-rc1, custom configured
ptal-init setup finds it.
Printing works fine via cups.
It used to work 1-2 months ago, but I may have been using kernel 2.4
then.  I never use rpm kernels.

sane-find-scanner finds the USB device.
but xsane doesn't find it (run as root or user).  scanimage -L doesn't
find it.

rpm versions:
hpoj-devel-0.91-7
hpoj-0.91-7
libsane-hpoj-0.91-7
sane-backends-1.0.14-4
xsane-gimp-0.92-13
sane-backends-devel-1.0.14-4
sane-frontends-1.0.12-3
xsane-0.92-13

Thanks,
--
Amish
Comment 5 Tim Waugh 2004-09-23 06:38:29 EDT
You may need to 'service hpoj setup' after uncommenting that line.
Comment 6 Amish S. Dave 2004-09-24 19:05:55 EDT
Sorry, tried this, no effect. 
 
Comment 7 Jerry 2004-11-15 01:00:21 EST
I had evrything working fine with psc2175 under Fedora Core 2.  When i
upgraded to FC3 it no work no more.  Found that line commented out.  I
noticed that there is a conflict between my usb memory stick and the
card reader in the psc2175.  I try to do lsusb and it hangs.  If I
unplug the psc and reboot, the try the memory stick, the udev system
finds the thing and it shows up reday to mount and works.  Soon as I
plug in the psc to its usb port, things don't work so well.  I gota
thread somewhere that stated that udev does not work so well with psc
type devices because they have multiple subnodes on one port.

Anyone have answers?  Suggestions?
Comment 8 Tim Waugh 2004-12-06 08:37:49 EST
Jerry: this bug report is about /etc/sane.d/dll.conf.  Please file a separate
bug report (against the kernel component) for the other issue you mention.
Comment 9 Tim Waugh 2005-08-04 06:40:49 EDT
We've switched to hplip in Fedora Core devel.

Note You need to log in before you can comment on or make changes to this bug.