This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1257730 - audit2allow calls missing checkmodule; possible dependency problem
audit2allow calls missing checkmodule; possible dependency problem
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Lautrbach
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 15:24 EDT by Ronald L Humble
Modified: 2015-09-03 23:22 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.4-11.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-03 23:22:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald L Humble 2015-08-27 15:24:50 EDT
Description of problem:"journalctl -xe" listed steps to alter local SELinux policy using audit2allow. Execution of audit2allow fails due to missing "checkmodule" program.


Version-Release number of selected component (if applicable):
policycoreutils-python-utils-2.4-10.fc23.x86_64

How reproducible: Fedora 23 Alpha KDE Workstation network install.


Steps to Reproduce:
1. grep httpd /var/log/audit/audit.log | audit2allow -M mypol
compilation failed:
/bin/sh: /usr/bin/checkmodule: No such file or directory
2.
3.

Actual results:


Expected results: Above audit2allow command runs to completion.


Additional info:
Installation of rpm packages "checkpolicy" fixes the above audit2allow command. Possible missing dependency in policycoreutils-python-utils-2.4-10.fc23.x86_64?
Comment 1 Petr Lautrbach 2015-09-01 10:54:23 EDT
Actually, it's policycoreutils-python3 what is missing dependency on checkpolicy. Thanks!
Comment 2 Fedora Update System 2015-09-02 03:38:26 EDT
policycoreutils-2.4-11.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14821
Comment 3 Fedora Update System 2015-09-03 05:53:02 EDT
policycoreutils-2.4-11.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update policycoreutils'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-14821
Comment 4 Fedora Update System 2015-09-03 23:22:53 EDT
policycoreutils-2.4-11.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.