Bug 1257738 - mod_ssl rpm is missing ssl_error_log from file list
mod_ssl rpm is missing ssl_error_log from file list
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Kaluža
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 15:43 EDT by Ronald L Humble
Modified: 2016-03-18 07:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-18 07:07:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald L Humble 2015-08-27 15:43:37 EDT
Description of problem:mod_ssl ssl.conf file lists /var/log/ssl_error_log as the default log location. This file does not exist in the rpm file list. "systemctl start httpd" fails.


Version-Release number of selected component (if applicable):
mod_ssl-2.4.16-1.fc23.x86_64

How reproducible:


Steps to Reproduce:
1. Install mod_ssl and configure.
2. "systemctl start httpd" fails due to above log file missing
3.

Actual results:


Expected results: Start of httpd with mod_ssl installed executes successfully. The log file exists and is SELinux friendly.


Additional info: I did
"touch /var/log/ssl_error_log; chown apache:apache /var/log/ssl_error_log"
Adjusted local SELinux policy.
"systemctl start httpd" executes; web server running as expected.
Comment 1 Joe Orton 2016-03-18 07:07:09 EDT
"chown apache:apache /var/log/ssl_error_log"

This is a very bad idea and is unnecessary.  The log file will be created at startup as required.  It's likely your SELinux permissions or similar are wrong on /var/log/httpd, preventing creation of the log file.  Or e.g. you are using a non-standard systemd unit file for httpd which doesn't start the parent as root.

Note You need to log in before you can comment on or make changes to this bug.