Bug 1257740 - Reported times in OpenSCAP 'Compliance Reports' list are wrong
Summary: Reported times in OpenSCAP 'Compliance Reports' list are wrong
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: SCAP Plugin
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Shlomi Zadok
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-27 19:48 UTC by Maxim Burgerhout
Modified: 2019-10-10 10:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:18:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Maxim Burgerhout 2015-08-27 19:48:39 UTC
Description of problem:
I just ran an OpenSCAP test, and manually made sure the report was uploaded to Satellite. The 'date' column on the 'Compliance Reports' page shows 'about 20 hours ago', but that's clearly not right.

The report itself shows the correct time though.

Version-Release number of selected component (if applicable):
ruby193-rubygem-foreman_openscap-0.3.2.10-1.el7sat.noarch
foreman-1.7.2.33-1.el7sat.noarch

How reproducible:


Steps to Reproduce:
1. Create SCAP content, policy
2. Manually run foreman_scap_client and smart-proxy-openscap-send
3. 

Actual results:
'Date' column on 'compliance reports' page shows 'about 20 hours ago'

Expected results:
Should be more like 3 minutes

Additional info:

Comment 1 Bryan Kearney 2015-08-28 17:35:17 UTC
Created redmine issue http://projects.theforeman.org/issues/11603 from this bug

Comment 3 Bryan Kearney 2015-11-01 11:02:05 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11603 has been closed

Comment 7 Kedar Bidarkar 2016-03-31 19:30:58 UTC
We can now see the compliance report "reported at" column in minutes and not just hours.

VERIFIED With sat62-snap6

Comment 9 errata-xmlrpc 2016-07-27 09:18:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.