Bug 1257745 - /etc/logrotate.d/tomcat tries rotating catalina.out instead of catalina.YYYY-MM-DD.log
/etc/logrotate.d/tomcat tries rotating catalina.out instead of catalina.YYYY-...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tomcat (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Knox
tomcat-qe
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 16:15 EDT by Yoshifumi Kinoshita
Modified: 2015-11-01 19:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-08 17:47:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 moraj 2015-09-03 12:49:45 EDT
I reported this behavior to Red Hat. I need some direction for an application I am setting up. What is the expected behavior for Tomcat? 

Should it be creating the log as catalina.out or as catalina.[YYYY.MM.DD].log?


The Logrotated conf file on RHEL 7.1 points to a catalina.out, but Tomcat is creating a catalina.[YYYY.MM.DD].log and it appears the log gets created each Tomcat is started.

Tomcat 6 on RHEL 6 created a catalina.out and Logrotated pointed to that file name. Was this feature deprecated in Tomcat 7 on RHEL 7?
Comment 3 Yoshifumi Kinoshita 2015-09-08 17:47:58 EDT
I found when we use /usr/sbin/tomcat to start tomcat, logs are written to catalina.out as well. So this is not a bug.
Comment 4 moraj 2015-09-08 22:36:48 EDT
I thought the Systemd was the preferred method for stopping and starting service on RHEL 7 not scripts/binaries found in /usr/sbin. When I use Systemd to stop and start Tomcat, Tomcat does not create a catalina.out as you have stated.

I have seen this issue on both CenOS 7 and RHEL 7.  

What is the preferred method for stopping the free/public version of Tomcat, /usr/sbin/tomcat or Systemd?
Comment 5 moraj 2015-09-08 22:38:56 EDT
Thanks but this doesn't help me nor help me how to fix the issue with starting/stopping Tomcat with Systemd.

Note You need to log in before you can comment on or make changes to this bug.