Bug 1257758 - [Docs] [Director] RFE add troubleshooting for overcloud node change problems
[Docs] [Director] RFE add troubleshooting for overcloud node change problems
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: y1
: 7.0 (Kilo)
Assigned To: Dan Macpherson
Deepti Navale
: Documentation, FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 17:59 EDT by John Fulton
Modified: 2016-01-11 05:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 05:14:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Fulton 2015-08-27 17:59:29 EDT
The following sections of our Director documentation [1]:

7.3. Scaling the Overcloud
7.4. Removing Nodes from the Overcloud
7.5. Replacing Compute Nodes

Should have corresponding troubleshooting sections that cover what to do in the cases where what is described above does not work. 

In general, the troubleshooting in Chapter 9 is focused on "day 1" problems with standing up your overcloud but not "day 2" problems with keeping your overcloud running. Starting your install over again in these scenarios is not acceptable if the recommended procedures don't work since you might disrupt a production overcloud. Thus, being able to troubleshoot these scenarios without disrupting the overcloud is important. Could there be additional entries in Chapter 9 on troubleshooting problems from 7.{3,4,5}? 

[1] https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/index.html
Comment 4 Andrew Dahms 2015-08-30 19:35:03 EDT
Assigning to Dan for review.
Comment 5 Andrew Dahms 2015-09-03 20:09:20 EDT
Changing the target milestone from y2 to y1.
Comment 10 Dan Macpherson 2015-09-17 21:15:32 EDT
John, just wanted to check -- any further feedback with the content in comment #9? Does this suit the requirements of the bug?
Comment 11 John Fulton 2015-09-17 22:03:08 EDT
Dan, looks good to me. Thanks.
Comment 17 Andrew Dahms 2016-01-11 05:14:05 EST
This content is live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.