Bug 1257760 - [RFE] OSE3 to assign a new namespace for everyuser like ose2
[RFE] OSE3 to assign a new namespace for everyuser like ose2
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.0.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Paul Weil
Johnny Liu
: Question
: 1059813 1243795 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 18:16 EDT by Ryan Howe
Modified: 2017-03-08 13 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-15 15:12:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1243795 None None None 2016-04-13 18:09 EDT

  None (edit)
Description Ryan Howe 2015-08-27 18:16:55 EDT
Currently, with OSE2 they utilize the namespace configuration so each user gets their own namespace, and every deployment is tagged with the user-name/ID for identification and to ensure there is no conflicts between any of the users.


OSE3 the routes can take any arbitrary value for the hostname. With V3 the name to be restricted to a specific sub-domain as we did in OSE2.
Comment 2 Ryan Howe 2015-08-31 15:57:39 EDT
This seems like it is already possible, this may need to be changed to an docs bug to better outline in more detail how one would accomplish this with v3 to mimic what v2 does.  

https://docs.openshift.com/enterprise/3.0/architecture/core_concepts/routes.html#custom-default-routing-subdomain
Comment 7 Timothy 2016-02-01 22:38:03 EST
Hey Ryan,

Aside from ensuring that there are no conflicts between any of the users, what other reasons would a user have for customizing the default routing subdomain?

Just trying to add some context.

Regarding your comment#2, what other technical details need to be added here?
Comment 8 Ryan Howe 2016-03-08 09:33:59 EST
Timothy, 

This bug what created to restrict users restricted to a specific default sub-domain. I would consider this RFE satisfied as we have outlined how set a default routing suffix. 

Best
Comment 9 Timothy 2016-03-14 23:36:35 EDT
Ryan,

I agree we show HOW to do this, but we don't really explain WHY you'd want to.

Can you please help me by answering the following:

Aside from ensuring that there are no conflicts between any of the users, what other reasons would a user have for customizing the default routing subdomain?

Thank you. :)
Comment 10 Ryan Howe 2016-04-13 18:02:16 EDT
This is related to bug https://bugzilla.redhat.com/show_bug.cgi?id=1243795


Bug is to use the following 

wordpress.myproject.apps.example.com 

instead of: 

wordpress-myproject.apps.example.com   


They want the namespace locked in to the default routing subdomain for each namespace. 


Example of how this might look in the master-config.yaml file. 

routingConfig:
  subdomain: {{ NAMESPACE }}.apps.example.com 

Where namespace is used as part of the domain.
Comment 11 Ryan Howe 2016-04-13 18:03:03 EDT
*** Bug 1243795 has been marked as a duplicate of this bug. ***
Comment 12 Eric Rich 2016-04-13 18:08:18 EDT
*** Bug 1059813 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.