Bug 1257776 - Replication not working for "delete: attr"
Replication not working for "delete: attr"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.6
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
: ZStream
: 1279926 (view as bug list)
Depends On: 1251288
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-27 21:13 EDT by Tom Lavigne
Modified: 2015-11-11 05:31 EST (History)
11 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-61.el6_7
Doc Type: Bug Fix
Doc Text:
Previously, when the user deleted an attribute without a value on the master server, the change was not replicated to other servers. The regression that caused this bug has been fixed. Now, after the user deletes an attribute without a value on the master server, the attribute is removed on all replicated servers as well.
Story Points: ---
Clone Of: 1251288
Environment:
Last Closed: 2015-09-22 10:02:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Lavigne 2015-08-27 21:13:33 EDT
This bug has been copied from bug #1251288 and has been proposed
to be backported to 6.7 z-stream (EUS).
Comment 3 Noriko Hosoi 2015-08-28 17:50:50 EDT
Steps to verify:
1. Set up MMR (hosts: Master1 and Master2)
2. delete an attribute without the value.
ldapmodify -h Master1 ... << EOF
dn: <DN>
changetype: modify
delete: <ATTR>
EOF
3. check the attribute <ATTR> in Master2.
   If it is deleted, the fix is verified.
Comment 5 Viktor Ashirov 2015-08-31 10:49:15 EDT
Build tested: 389-ds-base-1.2.11.15-61.el6_7.x86_64

[0] Setup MMR (M1 -- 1189, M2 -- 1289)

[1] Add test attribute:
[root@rhel6ds ~]# ldapmodify -D "cn=Directory Manager" -w Secret123 -h localhost -p 1189
dn: dc=example,dc=com
changetype: modify
add: description
description: test

modifying entry "dc=example,dc=com"

[2] It was replicated to the second master:
[root@rhel6ds ~]# ldapsearch -LLL -D "cn=Directory Manager" -w Secret123 -b "dc=example,dc=com" -h localhost -p 1189 -s base description
dn: dc=example,dc=com
description: test

[root@rhel6ds ~]# ldapsearch -LLL -D "cn=Directory Manager" -w Secret123 -b "dc=example,dc=com" -h localhost -p 1289 -s base description
dn: dc=example,dc=com
description: test

[3] Delete attribute without its value
[root@rhel6ds ~]# ldapmodify -D "cn=Directory Manager" -w Secret123 -h localhost -p 1189
dn: dc=example,dc=com
changetype: modify
delete: description

modifying entry "dc=example,dc=com"

[4] Change was replicated to the second master:
[root@rhel6ds ~]# ldapsearch -LLL -D "cn=Directory Manager" -w Secret123 -b "dc=example,dc=com" -h localhost -p 1189 -s base description
dn: dc=example,dc=com

[root@rhel6ds ~]# ldapsearch -LLL -D "cn=Directory Manager" -w Secret123 -b "dc=example,dc=com" -h localhost -p 1289 -s base description
dn: dc=example,dc=com

With the build 1.2.11.15-60.el6 attribute was present on the second master:
[root@rhel6ds ~]# ldapsearch -LLL -D "cn=Directory Manager" -w Secret123 -b "dc=example,dc=com" -h localhost -p 1289 -s base description
dn: dc=example,dc=com
description: test


Marking as VERIFIED.
Comment 7 errata-xmlrpc 2015-09-22 10:02:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1816.html
Comment 8 Ahmed Nazmy 2015-11-11 05:22:18 EST
*** Bug 1279926 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.