Bug 1257819 - [GSS] (6.1.z) Rules are not populated in dropdown list in Test Scenarios in BRMS 6.1
[GSS] (6.1.z) Rules are not populated in dropdown list in Test Scenarios in B...
Status: VERIFIED
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.1.0
Unspecified Unspecified
medium Severity unspecified
: CR1
: 6.1.5
Assigned To: Toni Rikkola
Tomas David
:
Depends On: 1257817
Blocks: 1281579 1281586
  Show dependency treegraph
 
Reported: 2015-08-28 02:45 EDT by Abhijit humbe
Modified: 2015-12-16 03:03 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1257817
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
abhumbe: needinfo-


Attachments (Terms of Use)

  None (edit)
Description Abhijit humbe 2015-08-28 02:45:06 EDT
+++ This bug was initially created as a clone of Bug #1257817 +++

Description of problem:
In Test scenario, show list option in new expectation not populating rules in drop down. This is working fine in 6.0.3. Take a look at attached screenshot.

Version-Release number of selected component (if applicable):

Actual results:
Rules are not populated in drop down list in Test scenario.


Expected results:
Rules should be populated in drop down list in Test scenario.

Additional info:
Comment 2 Toni Rikkola 2015-09-28 07:22:01 EDT
I tried the 6.2.x branch and it worked. I emailed the reporter for more detailed steps to reproduce. Going to test 6.3.x and master branch just to be sure, but it is likely that this bug has been fixed in the past.
Comment 4 Jiri Locker 2015-10-14 07:21:25 EDT
Hi, I have accidentally reproduced with a rule and a test scenario created in the default package (root, unnamed package, in Project Explorer displayed as <default>). I have also verified this use case works in 6.0.3 so this is most probably what doesn't work for the customer.
Comment 5 Toni Rikkola 2015-10-14 08:46:16 EDT
Ok, thank you this helps a lot. Taking a look.
Comment 6 Toni Rikkola 2015-10-14 09:41:02 EDT
Looks like the problem is related to the default package and I can reproduce it with both 6.1 and current master. Fixing ASAP.
Comment 7 Toni Rikkola 2015-10-15 07:57:14 EDT
The bug also affects the rule inheritance dropdown in guided rule and dtable editors. Lucene does not let us do a search with an empty string.
Comment 15 Tomas David 2015-12-16 03:03:31 EST
I created rules in default package and also in other non-default package and rules are populated in dropdown list correctly.

Tested on 6.1.5.CR1. Moving to verified.

Note You need to log in before you can comment on or make changes to this bug.