Bug 125782 - Changing "Status appears" option in Gimlet causes Gimlet to hog CPU
Changing "Status appears" option in Gimlet causes Gimlet to hog CPU
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: im-sdk (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Yu Shao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-11 09:20 EDT by Aaron Gaudio
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 11.4-46.1.svn1587
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-18 22:43:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Gaudio 2004-06-11 09:20:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Galeon/1.3.14

Description of problem:
If I change the 'Status appears' option (offering "Icon only", "Text
only" and "Icon and text") in the Preferences screen for Gimlet, it
goes haywire, taking up >90% of CPU until it is killed. In fact, you
don't have to even switch the option, just clicking the combo box
should do the trick. Changing the option does, in fact, apply the
change, however (assuming you can select it before your computer goes
out to lunch).

Version-Release number of selected component (if applicable):
iiimf-gtk-11.4-43

How reproducible:
Always

Steps to Reproduce:
1. Right click on the Gimlet applet in the panel and choose "Preferences"
2. Change the "Status appears" setting.
3. Watch your computer grind to a halt.
    

Actual Results:  The setting applies, but the gnome-im-switcher-applet
(aka "gimlet") starts taking up >90% CPU (verifiable via top).
Computer quickly becomes unusable.

Expected Results:  The setting shoudl apply, but gimlet should not
then start consuming CPU cycles.

Additional info:

I rebuilt my gnome-panel rpm in order to get the date applet to synch
with evolution 1.5. My rpm options use -Os instead of the default
optimizations.
Comment 1 Jens Petersen 2004-08-10 04:29:28 EDT
Could you please try to updating to the iiimf update in fc2-updates
and see if that works better for you?
Comment 2 Aaron Gaudio 2004-08-17 13:10:14 EDT
Yep, seems to be fixed with iiimf-gtk-11.4-46.1.svn1587.
Comment 3 Jens Petersen 2004-08-18 22:43:45 EDT
Thanks.

Note You need to log in before you can comment on or make changes to this bug.