Bug 1257830 - Error message "'list' object has no attribute 'split'" appears while setroubleshoot is processing AVC
Error message "'list' object has no attribute 'split'" appears while setroubl...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: setroubleshoot-plugins (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Petr Lautrbach
Milos Malik
:
Depends On:
Blocks: 1203710 1296594 1313485
  Show dependency treegraph
 
Reported: 2015-08-28 03:58 EDT by Jakub Filak
Modified: 2016-11-30 19:50 EST (History)
9 users (show)

See Also:
Fixed In Version: setroubleshoot-plugins-3.0.62-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:32:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Filak 2015-08-28 03:58:02 EDT
Description of problem:
After a new AVC is detected the following error appears in journal:
'list' object has no attribute 'split'

Version-Release number of selected component (if applicable):
setroubleshoot-3.2.24-1.1.el7.x86_64

How reproducible:
Sometimes

Steps to Reproduce:
1. provoke AVC

Actual results:
Aug 28 09:27:04 dhcp-24-114.brq.redhat.com setroubleshoot[4686]: failed to retrieve rpm info for /dev/vport0p2
Aug 28 09:27:04 dhcp-24-114.brq.redhat.com setroubleshoot[4686]: Plugin Exception restorecon_source
Aug 28 09:27:04 dhcp-24-114.brq.redhat.com setroubleshoot[4686]: SELinux is preventing /usr/bin/spice-vdagent from getattr access on the chr_file /dev/vport0p2. For compl
Aug 28 09:27:04 dhcp-24-114.brq.redhat.com dbus-daemon[658]: 'list' object has no attribute 'split'
Aug 28 09:27:04 dhcp-24-114.brq.redhat.com python[4686]: SELinux is preventing /usr/bin/spice-vdagent from getattr access on the chr_file /dev/vport0p2.
                                                         
                                                         *****  Plugin catchall (100. confidence) suggests   **************************
                                                         
                                                         If you believe that spice-vdagent should be allowed getattr access on the vport0p2 chr_file by default.
                                                         Then you should report this as a bug.
                                                         You can generate a local policy module to allow this access.
                                                         Do
                                                         allow this access for now by executing:
                                                         # grep spice-vdagent /var/log/audit/audit.log | audit2allow -M mypol
                                                         # semodule -i mypol.pp
Comment 2 Miroslav Grepl 2015-08-28 04:21:25 EDT
Could you attach raw AVC msg?
Comment 3 Milos Malik 2015-08-28 04:36:53 EDT
Every AVC seems to trigger it:

# grep split /var/log/messages
Aug 24 15:29:15 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 25 08:19:30 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 25 16:24:39 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 25 16:38:37 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 25 16:40:08 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 25 16:40:31 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 25 16:42:05 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 25 16:42:29 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 26 10:26:51 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 26 10:39:54 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 26 11:25:18 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 26 11:34:40 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 26 11:39:02 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 09:23:35 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 12:04:51 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 12:05:16 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 12:07:22 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 12:07:46 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 12:10:04 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 12:13:10 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 12:14:22 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 12:15:31 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 12:19:13 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 12:20:40 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 12:21:05 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 12:24:23 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 12:25:04 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 12:27:46 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 12:30:03 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 12:35:03 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 14:03:03 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 14:06:43 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 14:26:45 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 14:27:33 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 14:32:26 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 27 14:33:24 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 28 10:05:06 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 28 10:16:21 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 28 10:17:37 rhel72 dbus-daemon: 'list' object has no attribute 'split'
Aug 28 10:18:05 rhel72 dbus-daemon: 'list' object has no attribute 'split'
#
Comment 4 Jakub Filak 2015-08-28 04:39:55 EDT
time->Fri Aug 28 09:27:03 2015
type=SYSCALL msg=audit(1440746823.649:378): arch=c000003e syscall=4 success=no exit=-13 a0=409bd0 a1=7ffcaffb4790 a2=7ffcaffb4790 a3=7ffcaffb4480 items=0 ppid=4532 pid=46
76 auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 tty=(none) ses=4294967295 comm="spice-vdagent" exe="/usr/bin/spice-vdagent" subj=system
_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1440746823.649:378): avc:  denied  { getattr } for  pid=4676 comm="spice-vdagent" path="/dev/vport0p2" dev="devtmpfs" ino=8740 scontext=system_u:system
_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:virtio_device_t:s0 tclass=chr_file
Comment 6 Petr Lautrbach 2015-09-11 10:16:42 EDT
This is not a blocker material for rhel-7.2 however it's quite annoying and it should be fixed. Given that setroubleshoot-plugins tends not to be included on ACLs very often I would probably propose this for rhel-7.2.z update.
Comment 11 errata-xmlrpc 2016-11-04 02:32:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2441.html

Note You need to log in before you can comment on or make changes to this bug.