Bug 1257841 - [abrt] subscription-manager-gui: tick_cb(): python2.7 killed by SIGABRT
[abrt] subscription-manager-gui: tick_cb(): python2.7 killed by SIGABRT
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
abrt_hash:72211f2f1aabca2351c19d222c8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-28 04:31 EDT by Matej Habrnal
Modified: 2015-10-05 07:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-28 14:52:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (113.21 KB, text/plain)
2015-08-28 04:31 EDT, Matej Habrnal
no flags Details
File: cgroup (181 bytes, text/plain)
2015-08-28 04:31 EDT, Matej Habrnal
no flags Details
File: core_backtrace (26.25 KB, text/plain)
2015-08-28 04:31 EDT, Matej Habrnal
no flags Details
File: dso_list (18.94 KB, text/plain)
2015-08-28 04:32 EDT, Matej Habrnal
no flags Details
File: environ (183 bytes, text/plain)
2015-08-28 04:32 EDT, Matej Habrnal
no flags Details
File: limits (1.29 KB, text/plain)
2015-08-28 04:32 EDT, Matej Habrnal
no flags Details
File: machineid (135 bytes, text/plain)
2015-08-28 04:32 EDT, Matej Habrnal
no flags Details
File: maps (90.20 KB, text/plain)
2015-08-28 04:32 EDT, Matej Habrnal
no flags Details
File: open_fds (1.27 KB, text/plain)
2015-08-28 04:32 EDT, Matej Habrnal
no flags Details
File: proc_pid_status (1.04 KB, text/plain)
2015-08-28 04:32 EDT, Matej Habrnal
no flags Details
File: var_log_messages (29 bytes, text/plain)
2015-08-28 04:32 EDT, Matej Habrnal
no flags Details

  None (edit)
Description Matej Habrnal 2015-08-28 04:31:54 EDT
Description of problem:
After fresh installation of rhel7.2 I've tried to subscribe my system. Red Hat Subscription Manager crashed during verifying of subscriptions.

Version-Release number of selected component:
subscription-manager-gui-1.15.9-6.el7

Additional info:
reporter:       libreport-2.1.11
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/sbin/subscription-manager-gui
crash_function: tick_cb
executable:     /usr/bin/python2.7
kernel:         3.10.0-308.el7.x86_64
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 tick_cb at gtkprogressbar.c:604
 #5 gtk_widget_on_frame_clock_update at gtkwidget.c:5290
 #6 _g_closure_invoke_va at gclosure.c:831
 #8 g_signal_emit_by_name at gsignal.c:3405
 #9 gdk_frame_clock_paint_idle at gdkframeclockidle.c:380
 #16 gtk_main at gtkmain.c:1207
 #17 ffi_call_unix64 at ../src/x86/unix64.S:76
 #18 ffi_call at ../src/x86/ffi64.c:522
 #19 pygi_invoke_c_callable at pygi-invoke.c:628
 #20 pygi_function_cache_invoke at pygi-cache.c:793
Comment 1 Matej Habrnal 2015-08-28 04:31:57 EDT
Created attachment 1067928 [details]
File: backtrace
Comment 2 Matej Habrnal 2015-08-28 04:31:58 EDT
Created attachment 1067929 [details]
File: cgroup
Comment 3 Matej Habrnal 2015-08-28 04:31:59 EDT
Created attachment 1067930 [details]
File: core_backtrace
Comment 4 Matej Habrnal 2015-08-28 04:32:01 EDT
Created attachment 1067931 [details]
File: dso_list
Comment 5 Matej Habrnal 2015-08-28 04:32:02 EDT
Created attachment 1067932 [details]
File: environ
Comment 6 Matej Habrnal 2015-08-28 04:32:04 EDT
Created attachment 1067933 [details]
File: limits
Comment 7 Matej Habrnal 2015-08-28 04:32:06 EDT
Created attachment 1067934 [details]
File: machineid
Comment 8 Matej Habrnal 2015-08-28 04:32:08 EDT
Created attachment 1067935 [details]
File: maps
Comment 9 Matej Habrnal 2015-08-28 04:32:09 EDT
Created attachment 1067936 [details]
File: open_fds
Comment 10 Matej Habrnal 2015-08-28 04:32:10 EDT
Created attachment 1067937 [details]
File: proc_pid_status
Comment 11 Matej Habrnal 2015-08-28 04:32:11 EDT
Created attachment 1067938 [details]
File: var_log_messages
Comment 13 Adrian Likins 2015-09-08 20:31:44 EDT
I suspect this is related to https://bugzilla.redhat.com/show_bug.cgi?id=1247721 (and possibly fixed by same commit) but I'm not sure how it would haved caused a segfault. 

But... in the core_backtrace, there is also code in a different python context that is doing name resolution stuff.

ie:

           [ {   "address": 139631890442159
                ,   "build_id": "b0a1dfa62c6af7aa62487e3c260dc4b9c24d8bf8"
                ,   "build_id_offset": 1013679
                ,   "function_name": "__sendmmsg"
                ,   "file_name": "/lib64/libc.so.6"
                }
              , {   "address": 139631732344628
                ,   "build_id": "d08cf135d143704da93e5f025ae6ae6943838f03"
                ,   "build_id_offset": 46900
                ,   "function_name": "__libc_res_nsend"
                ,   "file_name": "/lib64/libresolv.so.2"
                }
              , {   "address": 139631732333735
                ,   "build_id": "d08cf135d143704da93e5f025ae6ae6943838f03"
                ,   "build_id_offset": 36007
                ,   "function_name": "__libc_res_nquery"
                ,   "file_name": "/lib64/libresolv.so.2"
                }
              , {   "address": 139631732336719
                ,   "build_id": "d08cf135d143704da93e5f025ae6ae6943838f03"
                ,   "build_id_offset": 38991
                ,   "function_name": "__libc_res_nsearch"
                ,   "file_name": "/lib64/libresolv.so.2"
                }
              , {   "address": 139631425178573
                ,   "build_id": "16fec8791a1ad2137e47effd8e110201f12ceb97"
                ,   "build_id_offset": 11213
                ,   "function_name": "_nss_dns_gethostbyname4_r"
                ,   "file_name": "/lib64/libnss_dns.so.2"
                }
              , {   "address": 139631890329832
                ,   "build_id": "b0a1dfa62c6af7aa62487e3c260dc4b9c24d8bf8"
                ,   "build_id_offset": 901352
                ,   "function_name": "gaih_inet"
                ,   "file_name": "/lib64/libc.so.6"
                }
              , {   "address": 139631890343853
                ,   "build_id": "b0a1dfa62c6af7aa62487e3c260dc4b9c24d8bf8"
                ,   "build_id_offset": 915373
                ,   "function_name": "getaddrinfo"
                ,   "file_name": "/lib64/libc.so.6"
                }
              , {   "address": 139631567861261
                ,   "build_id": "c61e79517deb9894892e057c5587a2dd0317038d"
                ,   "build_id_offset": 26125
                ,   "function_name": "socket_getaddrinfo"
                ,   "file_name": "/usr/lib64/python2.7/lib-dynload/_socketmodule.so"
                }


Which seems harmless, but registration does some strange name resolver klugery.
ie, registergui.py:reset_resolver() that uses ctypes to call glibcs __res_init().

Is /var/log/rhsm/rhsm.log from this machine available? If so, check if there is a "reset_resolver failed:" warning in the logs.

Hard to say if that could cause the segfault, but given resolver hackery, threads, event loop, etc I suspect it's related.
Comment 14 Adrian Likins 2015-09-08 21:24:20 EDT
(In reply to Adrian Likins from comment #13)
> I suspect this is related to
> https://bugzilla.redhat.com/show_bug.cgi?id=1247721 (and possibly fixed by
> same commit) but I'm not sure how it would haved caused a segfault. 

> Hard to say if that could cause the segfault, but given resolver hackery,
> threads, event loop, etc I suspect it's related.

Hmm, nm. Not a segfault, but a SIGABRT, which seems to come from

gtk+/gtk/gtkprogressbar.c in tick_cb:

g_assert (priv->pulse2 > priv->pulse1);

Which seems more likely to be caused by the issue fixed with https://bugzilla.redhat.com/show_bug.cgi?id=1247721
Comment 15 John Sefler 2015-09-25 12:56:32 EDT
as suggested by alikins in comment 14, the fix in https://bugzilla.redhat.com/show_bug.cgi?id=1247721#c4 was a likely fix for this bug too.  Please re-test with subscription-manager-gui-1.15.9-8.el7 or newer
Comment 16 John Sefler 2015-09-28 13:06:15 EDT
I am NOT able to reproduce the crash in comment 0 with RHEL-7.2-Snapshot-2.1 version....

[root@jsefler-rhel72-snap21 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.51.5-1
subscription management rules: 5.15
subscription-manager: 1.15.9-10.el7
python-rhsm: 1.15.4-5.el7
Comment 17 Barnaby Court 2015-09-28 14:52:10 EDT
Closing this issue as test was not able to duplicate it in RHEL-7.2-Snapshot-2.1
Comment 18 Matej Habrnal 2015-10-05 07:25:21 EDT
I tried to reproduce the crash with subscription-manager-gui-1.15.9-13.el7 and everything seems to work fine now. Thank you!

Note You need to log in before you can comment on or make changes to this bug.