Bug 1257847 - Dist-geo-rep: Geo-replication doesn't work with NetBSD
Dist-geo-rep: Geo-replication doesn't work with NetBSD
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
Unspecified NetBSD
unspecified Severity unspecified
: ---
: ---
Assigned To: Kotresh HR
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-28 04:58 EDT by Kotresh HR
Modified: 2016-06-16 09:34 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:34:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kotresh HR 2015-08-28 04:58:56 EDT
Description of problem:
Geo-replication doesn't work with NetBSD.
Lot of portability issues needs to be fixed.

1. gverify.sh needs to be portable.
2. lazy umount
3. ldconfig not finding libgfchangelog.so on source install
4. lgetxattr : libcxattr.py: errno from shared library is incorrect.
5. rsync and tar commands needs to be verified on NetBSD for the support
   of all the options.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
Geo-rep doesn't work with NetBSD.

Expected results:
Geo-rep should work with NetBSD as well.

Additional info:
Comment 1 Vijay Bellur 2015-09-04 05:25:36 EDT
REVIEW: http://review.gluster.org/12088 (geo-rep: Fix portability issues with NetBSD) posted (#2) for review on master by Kotresh HR (khiremat@redhat.com)
Comment 2 Vijay Bellur 2015-09-07 05:52:57 EDT
COMMIT: http://review.gluster.org/12088 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit dd09c684e0baec6ecde5736a1486f2bc4d3213ef
Author: Kotresh HR <khiremat@redhat.com>
Date:   Wed Sep 2 12:19:58 2015 +0530

    geo-rep: Fix portability issues with NetBSD
    
    Fixes portability issues in gverify.sh and
    libcxattr.py with NetBSD.
    
    Change-Id: Idfaa6cf3815136e6a2343aab98d979b6ab451bbd
    BUG: 1257847
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/12088
    Reviewed-by: Emmanuel Dreyfus <manu@netbsd.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 3 Mike McCune 2016-03-28 18:52:26 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Niels de Vos 2016-06-16 09:34:27 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.