Bug 1257857 - Configure kdump failed via NFS
Configure kdump failed via NFS
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.5.4
Unspecified Unspecified
medium Severity high
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Ryan Barry
wanghui
: Regression
Depends On:
Blocks: 1264358
  Show dependency treegraph
 
Reported: 2015-08-28 05:22 EDT by wanghui
Modified: 2016-03-09 09:36 EST (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-3.3.0-0.16.20151021git51ae965.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 09:36:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ovirt-node.log (10.90 KB, text/plain)
2015-08-28 05:22 EDT, wanghui
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46068 master MERGED kdump expects more and more -- create /var/crash on nfs ourselves Never
oVirt gerrit 46108 ovirt-3.6 MERGED kdump expects more and more -- create /var/crash on nfs ourselves Never

  None (edit)
Description wanghui 2015-08-28 05:22:21 EDT
Created attachment 1067944 [details]
ovirt-node.log

Description of problem:
It reports error while configure kdump failed via NFS.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.1-20150827.1.el7ev
ovirt-node-3.2.3-20.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor7-7.1-20150827.1.el7ev
2. Enable network
3. Configure Kdump via NFS type
4. Check #mount
5. Check /etc/kdump.conf file
6. Check the TUI page.

Actual results:
1. After step3. it reports error as follows.
KDump configuration failed, location unreachable. Previous configuration was restored.
2. After step4, it nfs location which I filled is already mounted.
#mount
10.66.65.196:/home/huiwa/nfs2 on /run/kdump-nfs type nfs4 (rw,relatime,vers=4.0,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=10.66.10.46,local_lock=none,addr=10.66.65.196)
3. After step5, NFS location is not saved in /etc/kdump.conf file.
4. After step6, TUI still shows Local as Kdump type.

Expected results:
1. Kdump via NFS should be configured without error.

Additional info:
Comment 2 Ryan Barry 2015-09-01 16:04:21 EDT
I can't reproduce this, and no changes have been made to the kdump code recently. Are you sure this isn't a problem with the environment?
Comment 5 Ryan Barry 2015-09-08 14:28:41 EDT
Still can't reproduce this.

If it's reproducible, can you please let me know the details of a system I can check it on, and the appropriate kdump path?
Comment 9 Ryan Barry 2015-09-11 11:27:15 EDT
It looks like I couldn't reproduce it (and QE didn't hit it earlier), because /var/crash already existed on my NFS share. If it doesn't, kdump now expects that users should create that manually...
Comment 10 Fabian Deutsch 2015-09-22 10:54:18 EDT
Lowering the priority because it happens only if the target dir is missing, and thus only affecting really new installs with non-existent target dirs.
Comment 13 wanghui 2015-10-26 03:21:33 EDT
Test version:
rhev-hypervisor7-7.2-20151025.0.el7ev
ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev.noarch

Test steps:
1. Install rhev-hypervisor7-7.2-20151025.0.el7ev
2. Enable network
3. From the remote NFS server, clean the target dir
4. Configure Kdump via NFS type
5. Check #mount
6. Check /etc/kdump.conf file
7. Check the TUI page.

Test result:
1. Kdump can be setup as NFS type succeed.

So this issue is fixed in ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev.noarch. Change the status to Verified.
Comment 15 errata-xmlrpc 2016-03-09 09:36:08 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html

Note You need to log in before you can comment on or make changes to this bug.