Bug 1257865 - Missing support for Windows Server 2012 R2
Missing support for Windows Server 2012 R2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libosinfo (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Matthias Clasen
Desktop QE
Lucie Maňásková
: Rebase
Depends On:
Blocks: 1295396 1297830 1313485
  Show dependency treegraph
 
Reported: 2015-08-28 05:34 EDT by Vaclav Ehrlich
Modified: 2016-11-04 00:42 EDT (History)
4 users (show)

See Also:
Fixed In Version: libosinfo-0.2.12-4.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
GNOME boxes support for Windows Server 2012 R2, Windows 10, and Windows 8.1 GNOME boxes now supports creating virtual machines with Windows Server 2012 R2, Windows 10, and Windows 8.1.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 00:42:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vaclav Ehrlich 2015-08-28 05:34:56 EDT
Description of problem:
Windows Server 2012 R2 is not supported by libosinfo. So `osinfo-detect win.img` shows only "Media is bootable". OS info is missing.
Also gnome-boxes failed to create new box.

Version-Release number of selected component (if applicable):
libosinfo-0.2.12-1.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. get windows iso
2. in terminal run command `osinfo-detect windows.iso`


Actual results:
Only "Media is bootable" is print out

Expected results:
OS info is print on terminal screen
Comment 2 Christophe Fergeau 2015-09-01 10:43:46 EDT
Can you provide the output of isoinfo -d -i win.iso ? If you have a f22 (or newer) install available, could you test if your iso is correctly identified there?
Comment 3 Vaclav Ehrlich 2015-09-10 10:42:10 EDT
isoinfo  -d -i en_windows_server_2012_r2_with_update_x64_dvd_6052708.iso
CD-ROM is in ISO 9660 format
System id: 
Volume id: IR5_SSS_X64FRE_EN-US_DV9
Volume set id: IR5_SSS_X64FRE_EN-US_DV9
Publisher id: MICROSOFT CORPORATION
Data preparer id: MICROSOFT CORPORATION, ONE MICROSOFT WAY, REDMOND WA 98052, (425) 882-8080
Application id: CDIMAGE 2.53 (01/01/2005 TM)
Copyright File id: 
Abstract File id: 
Bibliographic File id: 
Volume set size is: 1
Volume set sequence number is: 1
Logical block size is: 2048
Volume size is: 2635688
El Torito VD version 1 found, boot catalog is in sector 22
NO Joliet present
NO Rock Ridge present
Eltorito validation header:
    Hid 1
    Arch 0 (x86)
    ID 'Microsoft Corporation'
    Key 55 AA
    Eltorito defaultboot header:
        Bootid 88 (bootable)
        Boot media 0 (No Emulation Boot)
        Load segment 0
        Sys type 0
        Nsect 8
        Bootoff 876 2166
Comment 6 Zeeshan Ali 2016-01-18 11:45:40 EST
I suggest a rebase of libosinfo to 0.3.0 release.
Comment 7 Mike McCune 2016-03-28 19:47:57 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 10 Zeeshan Ali 2016-05-17 09:50:18 EDT
Switching to another advisory.
Comment 18 errata-xmlrpc 2016-11-04 00:42:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2367.html

Note You need to log in before you can comment on or make changes to this bug.