Bug 1257867 - Missing support for Windows 10
Summary: Missing support for Windows 10
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libosinfo   
(Show other bugs)
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Matthias Clasen
QA Contact: Desktop QE
Lucie Maňásková
URL:
Whiteboard:
Keywords: Rebase
Depends On:
Blocks: 1295396 1297830 1313485
TreeView+ depends on / blocked
 
Reported: 2015-08-28 09:37 UTC by Vaclav Ehrlich
Modified: 2016-11-04 04:42 UTC (History)
4 users (show)

Fixed In Version: libosinfo-0.2.12-4.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
GNOME Boxes now supports creating virtual machines with Windows 10.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 04:42:45 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2367 normal SHIPPED_LIVE gnome-boxes bug fix update 2016-11-03 13:50:33 UTC

Description Vaclav Ehrlich 2015-08-28 09:37:43 UTC
Description of problem:
Windows 10 is not supported by libosinfo. So `osinfo-detect win10.iso` shows only "Media is bootable". OS info is missing.
Also gnome-boxes failed to create new box.

Version-Release number of selected component (if applicable):
libosinfo-0.2.12-1.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. get windows iso
2. in terminal run command `osinfo-detect windows10.iso`


Actual results:
Only "Media is bootable" is print out

Expected results:
OS info is print on terminal screen

Comment 2 Christophe Fergeau 2015-09-01 14:44:09 UTC
Can you provide the output of isoinfo -d -i win81.iso ? If you have a f22 (or newer) install available, could you test if your iso is correctly identified there?

Comment 3 Vaclav Ehrlich 2015-09-10 14:56:26 UTC
isoinfo -d -i en_windows_10_enterprise_x86_dvd_6851156.iso
CD-ROM is in ISO 9660 format
System id: 
Volume id: J_CENA_X86FREV_EN-US_DV5
Volume set id: J_CENA_X86FREV_EN-US_DV5
Publisher id: MICROSOFT CORPORATION
Data preparer id: MICROSOFT CORPORATION, ONE MICROSOFT WAY, REDMOND WA 98052, (425) 882-8080
Application id: CDIMAGE 2.53 (01/01/2005 TM)
Copyright File id: 
Abstract File id: 
Bibliographic File id: 
Volume set size is: 1
Volume set sequence number is: 1
Logical block size is: 2048
Volume size is: 1420691
El Torito VD version 1 found, boot catalog is in sector 22
NO Joliet present
NO Rock Ridge present
Eltorito validation header:
    Hid 1
    Arch 0 (x86)
    ID 'Microsoft Corporation'
    Key 55 AA
    Eltorito defaultboot header:
        Bootid 88 (bootable)
        Boot media 0 (No Emulation Boot)
        Load segment 0
        Sys type 0
        Nsect 8
        Bootoff 222 546

Comment 4 Christophe Fergeau 2015-09-23 09:05:47 UTC
Should be fixed by https://www.redhat.com/archives/libosinfo/2015-September/msg00029.html

Comment 6 Zeeshan Ali 2016-01-18 16:45:00 UTC
I suggest a rebase of libosinfo to 0.3.0 release.

Comment 8 Mike McCune 2016-03-28 23:47:57 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 11 Zeeshan Ali 2016-05-17 13:48:50 UTC
Switching to another advisory.

Comment 19 errata-xmlrpc 2016-11-04 04:42:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2367.html


Note You need to log in before you can comment on or make changes to this bug.