Bug 1257869 - Missing support for Windows 8.1
Missing support for Windows 8.1
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libosinfo (Show other bugs)
7.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Matthias Clasen
Desktop QE
Lucie Maňásková
: Rebase
Depends On:
Blocks: 1295396 1297830 1313485
  Show dependency treegraph
 
Reported: 2015-08-28 05:43 EDT by Vaclav Ehrlich
Modified: 2016-11-04 00:42 EDT (History)
3 users (show)

See Also:
Fixed In Version: libosinfo-0.2.12-4.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
GNOME Boxes now supports creating virtual machines with Windows 8.1.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 00:42:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vaclav Ehrlich 2015-08-28 05:43:45 EDT
Description of problem:
Windows 8.1 is not supported by libosinfo. So `osinfo-detect win81.iso` shows only "Media is bootable". OS info is missing.
Also gnome-boxes failed to create new box.

Version-Release number of selected component (if applicable):
libosinfo-0.2.12-1.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. get windows iso
2. in terminal run command `osinfo-detect windows81.iso`


Actual results:
Only "Media is bootable" is print out

Expected results:
OS info is print on terminal screen
Comment 2 Christophe Fergeau 2015-09-01 10:40:43 EDT
Can you provide the output of isoinfo -d -i win81.iso ? If you have a f22 (or newer) install available, could you test if your iso is correctly identified there?
Comment 3 Vaclav Ehrlich 2015-09-10 11:01:52 EDT
isoinfo -d -i en_windows_8.1_n_with_update_x86_dvd_6051704.iso
CD-ROM is in ISO 9660 format
System id: 
Volume id: IR5_CCSNA_X86FRE_EN-US_DV9
Volume set id: IR5_CCSNA_X86FRE_EN-US_DV9
Publisher id: MICROSOFT CORPORATION
Data preparer id: MICROSOFT CORPORATION, ONE MICROSOFT WAY, REDMOND WA 98052, (425) 882-8080
Application id: CDIMAGE 2.53 (01/01/2005 TM)
Copyright File id: 
Abstract File id: 
Bibliographic File id: 
Volume set size is: 1
Volume set sequence number is: 1
Logical block size is: 2048
Volume size is: 1476196
El Torito VD version 1 found, boot catalog is in sector 22
NO Joliet present
NO Rock Ridge present
Eltorito validation header:
    Hid 1
    Arch 0 (x86)
    ID 'Microsoft Corporation'
    Key 55 AA
    Eltorito defaultboot header:
        Bootid 88 (bootable)
        Boot media 0 (No Emulation Boot)
        Load segment 0
        Sys type 0
        Nsect 8
        Bootoff 5B4 1460



isoinfo -d -i en_windows_8.1_enterprise_with_update_x64_dvd_6054382.iso
CD-ROM is in ISO 9660 format
System id: 
Volume id: IR5_CENA_X64FREV_EN-US_DV9
Volume set id: IR5_CENA_X64FREV_EN-US_DV9
Publisher id: MICROSOFT CORPORATION
Data preparer id: MICROSOFT CORPORATION, ONE MICROSOFT WAY, REDMOND WA 98052, (425) 882-8080
Application id: CDIMAGE 2.53 (01/01/2005 TM)
Copyright File id: 
Abstract File id: 
Bibliographic File id: 
Volume set size is: 1
Volume set sequence number is: 1
Logical block size is: 2048
Volume size is: 2021076
El Torito VD version 1 found, boot catalog is in sector 22
NO Joliet present
NO Rock Ridge present
Eltorito validation header:
    Hid 1
    Arch 0 (x86)
    ID 'Microsoft Corporation'
    Key 55 AA
    Eltorito defaultboot header:
        Bootid 88 (bootable)
        Boot media 0 (No Emulation Boot)
        Load segment 0
        Sys type 0
        Nsect 8
        Bootoff 86A 2154
Comment 4 Christophe Fergeau 2015-09-23 05:05:09 EDT
Should be fixed by https://www.redhat.com/archives/libosinfo/2015-September/msg00028.html
Comment 6 Zeeshan Ali 2016-01-18 11:33:38 EST
Can you please verify this is fixed in 7.2?
Comment 7 Zeeshan Ali 2016-01-18 11:36:43 EST
(In reply to Zeeshan Ali from comment #6)
> Can you please verify this is fixed in 7.2?

Ah, nm. The upstream patch came after our last libosinfo 7.2 changes so it's unlikely it was fixed in 7.2.
Comment 8 Zeeshan Ali 2016-01-18 11:44:26 EST
I suggest a rebase of libosinfo to 0.3.0 release.
Comment 10 Mike McCune 2016-03-28 19:47:57 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 13 Zeeshan Ali 2016-05-17 09:49:45 EDT
Switching to another advisory.
Comment 21 errata-xmlrpc 2016-11-04 00:42:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2367.html

Note You need to log in before you can comment on or make changes to this bug.