Bug 1257879 - cherry-pick patches to fix test issues on Django-1.8
cherry-pick patches to fix test issues on Django-1.8
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: z2
: 7.0 (Kilo)
Assigned To: Matthias Runge
Ido Ovadia
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-28 06:04 EDT by Matthias Runge
Modified: 2015-10-08 08:22 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-django-horizon-2015.1.1-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 08:22:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2015-08-28 06:04:05 EDT
Description of problem:


to fix tests there should be cherry-picked a few more fixes:
(unrelated nova data):
https://github.com/openstack/horizon/commit/bf1a2629f6d07e54b8840b9527d11d61eda6fa22

Don't escape request.get_full_path() in Django1.8 :
https://github.com/openstack/horizon/commit/7b4b527dc4042f10d51f2d93dc1707ffefa6902a
Comment 3 Matthias Runge 2015-08-28 08:12:54 EDT
These are fixed in liberty, and correcting tests.
Comment 8 errata-xmlrpc 2015-10-08 08:22:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1874

Note You need to log in before you can comment on or make changes to this bug.