Bug 1257880 - cli/quota: enhance CLI and quotad communication
cli/quota: enhance CLI and quotad communication
Status: CLOSED WONTFIX
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-28 06:05 EDT by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-15 01:48:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2015-08-28 06:05:25 EDT
In the current CLI framework CLI can hang when executing 'gluster volume quota volname list' if quotad is not running.
Bug# 1242819 has more information on this issue.

This is fixed with temporary solution: http://review.gluster.org/#/c/11990/


The temporary solution should be reverted once the CLI quotad communicated is enhanced in the framework

Below is the review comments from the patch# 11990

> Krishnan Parthasarathi		Aug 26 2:27 PM
>
> You could fix this by mimicking how CLI process ensures that it is connected to glusterd before sending RPCs. Note,
> this approach is not completely safe from a disconnect when an RPC is in flight.
> The time window where this could happen is small and we haven't seen it yet.
> The reason I suggest we do it this way is uniformity. Connections that CLI make should use the same pattern (read structure of code) to handle similar services.
> It gives us opportunity to fix issues that remain in the pattern once and reap benefits across problem areas.
>
> ## Implementation details
>
>  * See cli_cmd_needs_connection(), which returns a boolean depending on the cmd, e.g volume-start.
>
>  * See how cli_cmd_process uses the above function and state->await_connected to ensure that CLI is connected to glusterd before issuing any RPCs.
Comment 1 Vijaikumar Mallikarjuna 2016-02-15 01:48:36 EST
AS of now with the current CLI framework we will not be able to fix the problem. For now we will go with the current fix of using a separate thread to broadcast result: http://review.gluster.org/#/c/11990/

Note You need to log in before you can comment on or make changes to this bug.