Bug 1257946 - network service couldn't be started
network service couldn't be started
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukáš Nykrýn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-28 08:45 EDT by Parth
Modified: 2016-07-19 13:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 13:41:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sos report which has the message in /var/log/messages that indicates to report the bug.. (5.35 MB, application/x-xz)
2015-08-28 08:45 EDT, Parth
no flags Details

  None (edit)
Description Parth 2015-08-28 08:45:23 EDT
Created attachment 1067980 [details]
sos report which has the message in /var/log/messages that indicates to report the bug..

Description of problem:
I installed fedora 22 server in a testing environment. the installation is done through virtual box. I faced the problem on a cloned machine. When I tried to start network service on the cloned machine it did not start and was giving errors like below.. 

Aug 28 06:13:10 masti network[2021]: RTNETLINK answers: File exists
Aug 28 06:13:10 masti network[2021]: RTNETLINK answers: File exists
Aug 28 06:13:10 masti systemd[1]: network.service: control process exited, code=exited status=1
Aug 28 06:13:10 masti systemd[1]: Failed to start LSB: Bring up/down networking.
with such errors an error was logged in /var/log/messages which indicated me to report the bug to bugzilla. 


Version-Release number of selected component (if applicable):
[root@masti ~]# cat /etc/fedora-release
Fedora release 22 (Twenty Two)
[root@masti ~]#


How reproducible:


Steps to Reproduce:
1. Clone existing VM with option to assign new MAC and network type should be host-only Virtual Ethernet adapter.
2. Once the machine is up, change hostname, define gateway in network file and while NetworkManager is running try to start network service, it should fail! (it did not fail on the actual machine from which the clone is created. The network service fails even after correctng MAC address in interface file and commenting UUID number.)
3. Check /var/log/messages and you should see some long errors with message to report this to bugzilla.

Actual results:
Network service failed to start on clone. I tried to stop network and NetworkManager services. Network remained in failed state. NetworkManager could stop but after that too ifconfig and ip addr show command was showing the interface as up. After i brought down interfcae manualy with ifdown command and then when started network service the route was there and service started. 

Expected results:
Network service should have started and route for gateway should have been taken effect after Network service start followed by NetworkManager service stop and network service restart. ( this is how it happened in actual machine but in clone that was not the case)


Additional info:
Comment 1 Lukáš Nykrýn 2015-09-01 09:47:52 EDT
I am guessing that network.service was not running on you machine before. network-scripts and NM can coexists together only in the case that they were both started during boot.

If you are using NM simply don't use the old network-scripts.
Comment 2 Fedora End Of Life 2016-07-19 13:41:59 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.