Bug 1257968 - kinit stop working after ipa-restore
kinit stop working after ipa-restore
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-28 10:07 EDT by Martin Bašti
Modified: 2015-11-19 07:06 EST (History)
6 users (show)

See Also:
Fixed In Version: ipa-4.2.0-9.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:06:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
iparestore.log (2.26 KB, text/plain)
2015-10-13 05:34 EDT, Abhijeet Kasurde
no flags Details

  None (edit)
Description Martin Bašti 2015-08-28 10:07:50 EDT
Description of problem:
Unable to kinit on restored IPA server. (cannot login into webUI using login form too)

Version-Release number of selected component (if applicable):
ipa-server-4.2.0-8.el7.x86_64


How reproducible:
always

Steps to Reproduce:
1. yum install ipa-server ipa-server-dns
2. create snapshot
3. ipa-server-install --setup-dns
4. ipa-backup
5. revert snapshot
6. ipa-restore
7. ipactl start --force
8. kinit admin

Actual results:
# kinit admin
kinit: Resource temporarily unavailable while getting initial credentials


Expected results:
Receive krb ticket

Additional info:
There are more failures, but they may be caused by this issue.
named-pkcs11 failed to start
pki-tomcatd failed to start
Comment 3 Martin Bašti 2015-08-28 10:30:17 EDT
/etc/hosts has not been restored on my machine, so kinit cannot resolve IP address without running nameserver (named require krb ticket to run).

I will investigate why this has not been restored.
Comment 4 Martin Bašti 2015-08-28 10:43:10 EDT
Issue is the /etc/hosts it not configured to be backed up by ipa-backup.
Comment 5 Petr Vobornik 2015-08-31 12:20:41 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5275
Comment 10 Abhijeet Kasurde 2015-10-13 03:50:10 EDT
Verified.

IPA server version ::
ipa-server-4.2.0-13.el7.x86_64
Comment 11 Abhijeet Kasurde 2015-10-13 05:34 EDT
Created attachment 1082313 [details]
iparestore.log
Comment 12 errata-xmlrpc 2015-11-19 07:06:08 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2362.html

Note You need to log in before you can comment on or make changes to this bug.