Bug 1258004 - Wireless AC interfaces are not reliably detected
Wireless AC interfaces are not reliably detected
Status: CLOSED ERRATA
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification-hardware (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: brose
Brian Brock
:
Depends On:
Blocks: 1304756
  Show dependency treegraph
 
Reported: 2015-08-28 11:15 EDT by Greg Nichols
Modified: 2016-02-16 04:32 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.7.1-20160126.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1304756 (view as bug list)
Environment:
Last Closed: 2016-02-16 04:32:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Nichols 2015-08-28 11:15:22 EDT
Description of problem:

Wireless AC adapters are not reliably detected.   The wireless test uses "iw <interface name> link" to determine the connected "speed".  For AC, this varies quite a bit over time, and sometimes a G or N test is planned

Version-Release number of selected component (if applicable):

redhat-certification-hardware 1.6, 1.7

How reproducible:
Comment 1 Greg Nichols 2015-08-28 11:18:52 EDT
The suggestion is to use "iw phy0 info" to determine supported types/speeds.
Comment 2 Ken Benoit 2015-08-28 11:37:22 EDT
As in comment #1 it is recommended to use "iw <wireless phy name> info" to determine the hardware capabilities when choosing the test to plan. The phy number can be determined by calling "iw <logical device name> info" and looking at the "wiphy" field. In most cases where there is only one wireless card in the system this phy device will be "phy0".

Running "iw <wireless phy device, typically phy0> info" will print out the capabilities of the wireless card indicated.
* For wireless B you should look for the "Supported rates" section and see if the rates only go up to 11.0 Mbps (and 6.0 Mbps should not be listed).
* For wireless G you should look for the "Supported rates" section and make sure the rates go up to 54.0 Mbps. It should not contain a "VHT Capabilities" section nor should it list off "HT20/HT40" in the "Capabilities" section.
* For wireless N if you look under the "Capabilities" section "HT20/HT40" should be listed. There should be no "VHT Capabilities" section.
* For wireless AC there should be a "VHT Capabilities" section and "short GI (80 MHz)" should be listed (as wireless AC requires 80 MHz channel width in the spec).
Comment 4 Brian Brock 2016-01-29 17:25:14 EST
The most recent results for the wireless tests (all flavors) pass and no problems were seen.

redhat-certification-2.2-20160126.el7
redhat-certification-hardware-2.2-20160128.el7
Comment 6 errata-xmlrpc 2016-02-16 04:32:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0194.html

Note You need to log in before you can comment on or make changes to this bug.